WRV54G v2.36 firmware and VPN client

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by eric_stewart, Sep 9, 2004.

  1. eric_stewart

    eric_stewart Super Moderator Staff Member Member

    Believe it or not, Linksys has posted both new firmware *and* a VPN client on their website today.

    I can hardly wait to get into work tomorrow and try them out.

    Here's the info from the readme file (curiously, it refers also to a version which never made it "to press")

    Note also that Jon Althoff mentioned in this forum that the Intel processor VPN patch hadn't been applied yet in the 2.25 firmware. It looks like someone was listening...

    --------------------------------<quote from readme>-----------------

    Firmware Date: 9/7/2004

    Release Date: 9/8/2004

    Last Firmware Version: 2.36
    Firmware version 2.36
    - Added Linksys QuickVPN support under Access Restrictions tab

    ***WARNING***: To ensure proper upgrade, the router will automatically reset to factory defaults! Write down all configuration before performing this upgrade.

    Firmware version 2.31
    - Updated wireless settings to improve stability
    - Resolved issue with Syslog security vulnerability
    - Resolved issue with IPSec Passthrough MTU
    - Resolved issue with VPN tunnels blocking normal http traffic
    - Resolved issue with Static Routing table on the GUI
    - Resolved issue with DDNS updates interrupting VPN tunnels
    - Resolved issue with Main task crash resulting in socket errors
    - Applied Intel VPN code patch
  2. TazUk

    TazUk Network Guru Member

    So we go straight from 2.25 to 2.36 8O wonder why the interim releases weren't made available :roll:

    There's not mention on there of fixing the NAT-T issue, this was/is one of the biggest problems with this router :?
  3. JonAlthoff

    JonAlthoff Network Guru Member

    Intel VPN Code patch could possibly be the NAT-T fix. I beleive Intel had done some modification to the freeswan VPN. They could possibly have fixed it in this.

    I've started setting up tunnels and the first FQDN tunnel did not connect. The 4 previous tunnels had Static IP addresses and connected instantly.

    I'll make some notes while I configure them
    IP - BEFVP41 V1 firmware 1.41.1 connected
    FQDN - BEFVP41 V1 firmware 1.41.1 connected
    FQDN - BEFVP41 V1 firmware 1.41.1 waiting for connection but connected
    FQDN - BEFVP41 V2 firmware 1.00.10 needs updated to 13
    FQDN - BEFVP41 V2 firmware 1.00.13 connected
    2nd FQDN - BEFVP41 V2 firmware 1.00.13 says it's not connected but can ping remote network. Closed browser. Says "waiting for connection" but ping to remote network still works.

    IP - FVS318 firmware 2.1 disable authentication could not connect
    FQDN - FVS318 firmware 2.4 connected think I had to use 768bit PFS group. Will check more. Not sure about settings for Authentication MD5/SHA settings.

    Now that I am thinking about it Intel did release a bug fix so the NAT-T may no be fixed unless the Linksys VPN Client resolves this.

    For the most part my VPN Tunnels connected pretty well. Now the only thing is to see how long they last and how well they reconnect without difficulty when they crash. I'll check at the shop to see if I can connect with the VPN Client from behind a WRT54G.
  4. James448

    James448 Network Guru Member

    I sure hope the VPN works well with this new firmware, problem is my client is on Bellsouth DSL and this firmware wont work with Bellsouth!!!
    Lucky me, waited 3 weeks for working VPN firmware but now the dumbass device wont even route now....

    I have a similar problem with the RV042, check that thread.

    Now I have 2 boat anchors not 1, thanks Linksys.

    PS- get your heads out of your asses and make firmware compatible with bellsouth DSL, Im sure your aware of their differences so how hard can it be to include compatible code?
  5. JonAlthoff

    JonAlthoff Network Guru Member

    Updated. Found the configuration settings for VPN client in WRV54G.

    Well, I loaded the QuickVPN program from Linksys. I'm not sure if it is a bad joke or what. It didn't appear to have any functionality whatsoever.


    Profile name is pretty self explanatory.
    User Name and Password?
    Server Address is also pretty self explanatory but didn't seem to work with a FQDN.
    Maybe This is for HotSpot functions through a VPN tunnel.

    So far my VPN tunnels have gone downhill. The ones that use FQDN and DSL that will change frequently are not connected. The ones static and roadrunner with infrequently changing IP addresses appear okay.
  6. eric_stewart

    eric_stewart Super Moderator Staff Member Member

    The VPN Client works fine...at least in my lab environment. Not sure what you mean by its being some kind of bad joke? I'm able to use it to access the inside, protected network on the "other side" of the WRV54G

    You need to configure VPN users in the "access restrictions" menu on the router. This is why the VPN client prompts for username/password. Much of this is explained in the readme files attached to the router firmware and the VPN client ;-)

  7. JonAlthoff

    JonAlthoff Network Guru Member

    Sorry, I updated it after I someone informed me of my lack of research on the WRV54G pages. I of course expected to connect using a standard VPN tunnel configuration like the BEFVP41 or many of the other VPN routers. This seems to be to be a cheesy way around the problem. Now I will have to have 2 separate VPN programs to connect to different VPN routers.

    I wasn't able to do a whole lot from my remote computer at the shop. could sometimes ping computers behind the WRV54G and sometimes not. I could not ftp to my private IP address for my ftp server behind the WRV54G and various other things. I could however ping NON-existant ip addresses behind the WRV54G.
  8. JonAlthoff

    JonAlthoff Network Guru Member

  9. JonAlthoff

    JonAlthoff Network Guru Member

    I suppose I should have been smart enough to look through all of the configuration pages. I think somewhere I read it before as well. I am already using a 10.x.x.x subnet for almost all of my locations. It makes things much easier for me to remember. 10.34.88.x for home since my address is 3488. 10.27.27.x for the shop since the address is 2727.

    I created a profile on QuickVPN and a user name on my router with a password. I am able to connect. I can sometimes ping my router at I can sometimes ping my Win2k3 server at I cannot ping my Windows XP SP2 machine at I can sometimes ping my wireless NIC in my laptop at I can ping something unknown at from the shop and cannot from home. I can ping a Windows XP SP2 computer at I tried just as something I think is non existent and it would ping find from shop and not from home computers. I cannot ftp to my ftp server either.

    I also have not been able to reverse ping back to from home. DHCP is disabled in my WRV54G and runs on my Win2k3 server. This was I can statically assign my IP addresses.
  10. TazUk

    TazUk Network Guru Member

    Jon could you edit your post and use the [url= tag so the link isn't so long, at the moment it's difficult to read things as the page is so wide 8O
  11. Toxic

    Toxic Administrator Staff Member

  12. TazUk

    TazUk Network Guru Member

    Yep, cheers :D
  13. TazUk

    TazUk Network Guru Member

    It seems this new firmware does not fix the NAT-T issues :cry: A quick test using both SSH Sentinel and Linksys's own VPN client failed :roll:
  14. EliottNess

    EliottNess Guest

    QuickVPN Hang under WinXP SP2

    Hello All,
    I've updated to last firmware & installed QuickVPN Software.
    All is setup correctly on the WRV54G.
    The QuickVPN start the connexion and then hangs saying "Verifying Network".
    The IPSEC VPN looks like correctly setup, but doesn't work.

    Any Clue ?
  15. JonAlthoff

    JonAlthoff Network Guru Member

    Wasn't or isn't there some IPSEC stuff you need to load from Microsoft? Was that done?

    For some reason I remember something about installind IPSECCMD

    I found this as well doing a search but have not looked into it.

  16. Gallardo

    Gallardo Network Guru Member

    HI @ll!

    The Linksys VPN Client also uses the ipseccmd.exe...
    just for information ;)

    -> is the bug about the firewall & remote management fixed in this version?? (remote managment doesn't work if firewall is switched on... -> blocked by fw rule..)
    I currently have the 2.21 EU Version and so i have to forward the port to the internal ip of the router...

    by the way, who is already working on compiling the firmware theirselves?

    greetz Gallardo
  17. JonAlthoff

    JonAlthoff Network Guru Member

    I gave up. It was too difficult for me with my limited knowledge. I am however reading up on the subject.

    I have all kinds of information available if you need it.
  18. Kaitain

    Kaitain Network Guru Member

    NAT Transversal Bug Fixed?

    I see one person says they can not connect behind a NAT to the router. Has anyone been successful with this?

    Right now this router is a $180 paper weight. If they haven't fixed the NAT-T problem, it will continue to be so.

    I've downloaded the latest Firmware and have the QuickVPN client on my laptop so will test this tomorrow. I've got an even more complicated setup, I've got a Motorola VoIP box connected to my Cable Modem, then my router. I sure hope this new fix works through NAT's.
  19. etkal

    etkal Network Guru Member

    Re: QuickVPN Hang under WinXP

    I get the exact same symptoms. In order to rule out NAT, I set up a local network with the client system on the same subnet and got the same results. I have WinXP SP1.

    Come on Linksys, this isn't rocket science, you know... :-/

    Erik Tkal
  20. TazUk

    TazUk Network Guru Member

    I had the Linksys QuickVPN client working fine but this was under Windows 2000 with SP4. No special configuration in Windows was necessary, just installed the software, ran it, filled in the boxes and it connected :)
  21. Zippo

    Zippo Network Guru Member

    I got the client on XP to connect to the router. I can ping and config through the VPN with oout a problem. How do I connect to machines inside the network.

  22. etkal

    etkal Network Guru Member

    Re: QuickVPN Hang under WinXP

    Ok, I tried running the VPN client from work to my home system, and now I actually show as being connected. However, I have no idea how to use the connection. There is no virtual LAN adapter, and my routing table has not been modified. Is the client supposed to do something to this effect? For example when I install the Contivity VPN client it gives me a virtual adapter that is used as my end of the tunnel.

    Also, any idea what VPN protocol is used by the WRV54G and Linksys VPN Client? PPTP? L2TP? The contivity client won't talk to the WRV54G, even though it appears that it should be compatible. Is the Linksys connection proprietary?

    Erik Tkal
  23. Zippo

    Zippo Network Guru Member

    Ok after a restarted I am working just fine. First thing I did was ping the private IP address of the router once connected with the VPN client. After that I was able to ping other machines inside the private network. I also tried a drive MAP and a remote desktop connection. All of them worked fine. I did not have to set up any tunnel information or anything like that. The VPN client seems to make its own dynamic tunnel and you can just pass traffic through it. I am glad to have this working.

  24. demko

    demko Network Guru Member

    Any success with connecting with a MAC?

    Has anyone had any success with connecting to this VPN router from a MAC? I've been trying with the built in VPN client on OS-X with no success. Has anyone had any luck?
  25. TazUk

    TazUk Network Guru Member

    Are you behind a router running NAT?
  26. demko

    demko Network Guru Member

  27. TazUk

    TazUk Network Guru Member

    That's why, the WRV54G doesn't seem to support NAT-T, which is required when connecting from behind a NAT enabled router :?
  28. cyberpsych1

    cyberpsych1 Network Guru Member

    Do the following:

    1) Disable PPTP, L2TP, IPSEC Passthrough
    2)Disable Vpn tunnel, Vpn gateway, key management and pfs
    3) Disable all port forwarding (e.g. 1723, 1701, 500, 4500)

    The linksys quickvpn will create its own secure connection with the wrv54g. I can connect consistently with the above actions applied.

    Additional Info:


    Also, WRV54G does support NAT-T...
  29. TazUk

    TazUk Network Guru Member

    Not according to SSH Sentinel it doesn't :?

    And disabling "Vpn tunnel, Vpn gateway, key management and pfs" isn't an option if you also want to use it to conect to another VPN router, such as a BEFVP41.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice