WRV54G vpn passthrough strange

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by ITman, Jul 22, 2005.

  1. ITman

    ITman Network Guru Member

    This is my first post here and I haven't done an extensive search yet, but I am wondering if someone has a quick answer to this.

    I am able to establish a Microsoft PPTP and L2TP/IPSEC tunnels to my work with no problems. I can even access SOME resources on the vpn network, but the VPN behaves very strangly. For example: I can open my MS Exchange mailbox in Outlook, I can mark items read/unread but I CANNOT open them. I can connect to an internal website, but I cannot use any of the forms on it, etc, etc, etc... On the corporate firewall I get weird IP related errors caused by the tunnel connection.

    My set-up is like this: WinXPSP2-->WRV54G/NAT-->Internet-->FIREWALL/NAT-->VPNServer-->CorpNAT

    I know that even MS doesn't support this configuration, BUT it works fine on BEFSX41 (I installed it half a dozen time and it works fine) Something in WRV54G vpn passthrough implementation is broken as compared to BEFSX41. I am using official linksys 2.37 firmware.

    Is this a known issue? Is there a beta firmware release that fixes this?
  2. TazUk

    TazUk Network Guru Member

    Have you tried changing the size of the MTU ?
  3. ITman

    ITman Network Guru Member

    Yep, that did it. Changed it from Auto to 1500 and now everyting is OK. Thanks!
  4. TazUk

    TazUk Network Guru Member

    Glad it worked :D

    Just goes to show though how p**s poor Linksys are at testing their products :roll:
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice