WRVS4400n and Quick VPN: The Remote Gateway is not Responding

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by GdnMatrix, Dec 10, 2007.

  1. GdnMatrix

    GdnMatrix LI Guru Member

    Hey, all

    Great Linksys Forum Community BTW!!!

    I recently purchased an WRVS4400N VPN router hoping it would do two things for me.

    1 - Faster, longer range wireless connectivity with 802.11n

    2 - Allow me to VPN from my work office to my WRVS4400n router/Cable modem (at home) and connect to the internet on my home highspeed broadband connection.

    Well, so far I have been only successful with the faster and longer range connectivity.

    I have not been successful in accessing my home broadband connection. With QuickVPN I can make a connection, but I keep on getting "The Remote Gateway is not responding".

    I have read through the forums and searched on this msg and have tried various possibilities and still no luck.

    One of the reason's I bought this router was that at work they have implemented WebSense (Content Filtering) and have "locked" down the network pretty tightly and I wanted a way to still be able to access my "personal" email and "stocks" from the office. I have basic knowledge on "Networking and routing" and I thought I would be able to VPN into my home broadband connection from work and get out to the internet using my high speed home modem with no "content filtering".

    So the question I have to the community is:

    Is my understanding and expectation incorrect about being able to VPN from my office to my home broadband connection? If not, then what am I doing wrong. Any help would be appreciated.

  2. GdnMatrix

    GdnMatrix LI Guru Member

    87 Views and no replies. Must be a common problem! LOL ;-)
  3. vpnuser

    vpnuser LI Guru Member

    QuickVPN (IPSec) into your home WRVS4400n through your company's firewall may be blocked due to IT policy. You might want to test your first QuickVPN connection over the internet right off a hotspot.
  4. GdnMatrix

    GdnMatrix LI Guru Member


    Thanks for taking a moment to reply. Is there a log somewhere (QuicVPN) that would show that the company's IT policy would not allow me to make a VPN connection out of the company's network?
  5. vpnuser

    vpnuser LI Guru Member

    According to the release note of QuickVPN Client 1.2.8, there is a log.txt file that might show this.
  6. DocLarge

    DocLarge Super Moderator Staff Member Member


    quickvpn is not going to show the policy of your company; it may show you reasons it has not connected, but that's about it. To get a better view of what's happening upon connection, you might download either "wall watcher" or "link logger." Both of these are logging applications.

  7. bgriggs75

    bgriggs75 LI Guru Member

    I'm having this same problem, only I'm running a cable directly from my PC to the WAN port on the router, with both XP and the router firewall disabled. Wanted to make sure the client VPN worked back-to-back before I deployed to the field. The router thinks I'm connected (shows user online and duration) and the client "time connected" continues to increase but I'm not able to ping either way (and yup, the subnets are different).

    I've had nothing but trouble trying to get client VPN to work on this router. Any ideas?
  8. mghtbgiant

    mghtbgiant Guest

    simply befuddled

    i cannot believe that i have seen posts on this topic all the way back in 2006.. here it is 11/2008 and i am (and im sure many other people) encountering difficulty between a piece of linksys equipment and their trusty quick VPN app.

    i have a wrvs4400N, which, to be honest, if i were still in my 30 day trial period, would have returned quite some time ago. its VPN functionality was what caught my eye initially, and its the most messed up POS ive ever tried configuring. i come from a windows background, and i feel that for me, building a slackware linux machine from the ground up was way easier than this.

    ill try to detail everything to this point: like i said, i bought this particular router for its VPN capability. i tried configuring it when i first got the router, to no avail.. i chalked it up to my ignorance and was otherwise quite content with it. that was probably 4 months ago.. fast forward to today. i recently came into a scenario where i need to be able to access my home network from the internet. ive always liked the idea, but never really had a need to fight it into workage (hence giving up 4 months ago).

    i have gone through Docs post (and all subsequent replies) on how to get quick VPN working.. and, after finally finding that post last night, i was able to get quick VPN to connect, and i was even able to browse my NAS.

    heres where i started.. i installed quick vpn first.. i would continually get the "verifying network" hang.. with it ultimately saying "the remote gateway is not responding. do you want to wait?". i then came across threads talking about greenbows ipsec vpn client which i installed and tried.. i knew then, that it wasnt what i needed given my hardware, but i tried it anyway.. after very haphazardly slapping in settings all over the place that im sure were entirely wrong.. SURPRISE.. it wouldnt connect.. no big deal.. by this point im grasping for straws after reading everyone elses plight in this arena..

    somewhere along the way in all these installs, i came across a thread that said to reset to factory defaults, and reload the latest firmware.. so, i did that.

    NEXT.. so, then i google more and come across an IPSec VPN client called cyberoam. i install it.. but, to my surprise, it says its already installed and makes me uninstall greenbow.. odd.. whatev.. same interface.. same stuff.. same result.. THEN, i installed CiscoVPN which i use at work for customer servers. nope, this isnt what i need either..

    it was at this point that i came across Docs tutorial. the holy grail.. i mightve just found the key to the universe.. i go through and make sure of the following:

    - under Firewall/Basic Settings, Enable Remote Access (8080), Enable HTTPS.. not sure if remote access is necessary, but in my router that is the only place to enable HTTPS is if remote access is enabled.

    - under VPN/VPN Client Accounts, i created a new user a la test/tester.

    - under VPN/VPN PassThrough, i disabled L2TP (left IPSec & PPTP PassThroughs enabled)

    - under Administration/Management, i disabled UPnP (SNMP was disabled by default)

    - under Setup/WAN, i set MTU to manual and went with the 1458 size.

    then, i saw something i hadnt come across in threads before.. i needed to check to see if my IPSec service was running.. it was disabled (probably via domain policy at work). so, i set the service to automatic, and started it.

    somewhere in here i also did the DrTCP thing and set the MTU locally but i dont think that really did anything because all the adapters listed in the dropdown were disabled..

    i was still having issues, so i went back to the router and under Firewall/Basic Settings i disabled the firewall, and DoS protection. at this point, block WAN request had long since been disabled because the only message i saw in the log was [WARNING] Failed to ping the remote VPN Router! so i thought it was really just trying to ping it and block WAN request was preventing that from passing... umm.. not so much.

    anyway... somehow, in all of this mix.. it connected.. IT ACTUALLY CONNECTED.. i immediately went to windows explorer and tried to get to my NAS.. there it was.. SUCCESS.. so, in typical stupid me fashion, i start removing unnecessary stuff.. namely all the superfluous VPN clients i had installed along the way that werent needed.. at this point i started changing a couple seemingly innocuous settings on the router.. i wanted to work back and find the EXACT cause of the hiccup for me, as it might help someone else.

    well.. ever since that moment.. i have not been able to reconnect.. no matter what i do.. i have tried to retrace all of the app installs.. all of the setting changes.. i reset the router to factory defaults and reflashed the firmware.. and let me just say.. the latest firmware for this router is from friggin 10/2007.. wtf linksys?!? for a $250 router??!? rreeeaaallyy????

    anyway.. i had another laptop just sittin next to me which didnt even dawn on me.. so i thought i would try to connect on it.. and heres where it gets REALLY weird.. on my laptop, i would be sure to disable all of my other network adapters that werent being used for the vpn connection. so, the other laptop has vista SP1.. my laptop runs xp SP3. i installed all the software on the 2nd laptop and got ready to fire up good ole QVPN. i go to disable the wireless adapter.. foreshadowing here is i THOUGHT i disabled it, but in vista this requires an extra "do you REALLY REALLY want to disable this??" which i didnt click.. so, i fire up QVPN and it connects RIGHT off the bat.. first try.. i go to access the network share and it comes up instantly.. okay, this is a little weird.. this whole time i am using my cellphones modem to connect from an outside IP and the share shouldnt have come up that fast.. so, i check.. sure enough, the wireless adapter is still enabled.. so, i disable it.. and the QVPN connection drops.. and i cant reconnect.. however, i enable the wireless.. i can connect via QVPN.. now, at this point, i KNOW QVPN can NOT be connecting through the wireless adapter because there would be an IP address conflict.. so, i have no idea whats going on here.. QVPN is connecting through my cellmodem but somehow needs the wireless connection to be up?? dunno.

    at this point.. day 2 of ruined evenings.. im giving up.. im asking linksys why this is still such a freakin heading with posts on this topic dating back 2 years.. why hasnt there been a later release of firmware for the wrvs4400n.. right now, i would LLLOOOVVEEEE to have my money back for this POS that doesnt do what it advertised to do.

    i am completely friggin exhausted.
  9. bgriggs75

    bgriggs75 LI Guru Member

    Update from me

    Well, seeing your troubles, giant, I figured I'd update on my solution. Sold the 4400N on e-bay to re-coup some of my costs, used the money to get an older Linksys to run DD-WRT firmware so I wouldn't have to deal with terrible Linksys firmware and support anymore, and have set up a router-to-router IPSEC VPN that NEVER goes down. No, it wasn't easy and required some command-line type configuration but the DD-WRT community is much more helpful than the overseas hired help from Linksys.

    My conclusion: The WRVS4400N is a terrible router. Cisco has no interest in developing a true SMB business-class router from Linksys because it would eat into their own branch-in-a-box solution revenue. They also don't care if they do damage to the Linksys brand because it is most likely going away at some point. DO NOT BUY THIS ROUTER! But don't take my word for it - read the reviews on newegg.com.
  10. Oreganoflow

    Oreganoflow Addicted to LI Member

    I don't understand everyone's frustration with this router. I've had it up and running for a little over a month now with the following all working:

    - 11 VOIP phones with QOS priority (we had an issue with choppy VOIP calls which is why we purchased the router. Works great now!
    - Web Server behind the firewall with ports 21,22, 80 and 443 forwarded to it
    - 48 server and PC connections
    - VPN with all 5 accounts working with Quick VPN
    - Firmware 1.1.12

    My only slight complaint is the wireless seems to drop from time to time. I don't use wireless much though.

    Other than that, I'm quite pleased with the purchase.

    As far as quickVPN, I think the only thing I altered was enabling remote access.

    It took me about a week to get everything up and running and Linksys tech support was a great help.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice