WRVS4400N Beta Firmware?

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by reb0, Feb 16, 2007.

  1. reb0

    reb0 LI Guru Member

    Any time frame when the GPL-sources or a similar Beta for the WRVS4400N (=RVS4000 + WLAN, just a recompile necessary) will be available?
  2. Toxic

    Toxic Administrator Staff Member

    Sorry I dont know of any at present.
  3. Infobits

    Infobits LI Guru Member

    In my reports to Linksys Tech support about wireless problems on my WRVS4400N router, they said that there is a beta firmware that they are testing with at this time 1.00.13 or something like that. They just sent it to me to at my request to help test it even though she said that the release notes for this beta firmware make no mention of fixing the bugs I was reporting. She said nevertheless she is sending it to me to try out. Sheesh and I just RMA shipped back my router just this afternoon for an exchange of another new one, so I don't have it to load the beta firmware. I will have to wait for the 2nd router to be delivered to me sometime this coming week. So there is a beta firmware, just not readily available just yet to the general public.
  4. reb0

    reb0 LI Guru Member

    Only a few hours after my first posting they released the GPL-sources for 1.00.13: ftp://ftp.linksys.com/opensourcecode/wrvs4400n/1.00.13/WRVS4400N_v1.00.13.tar.gz

    They increased the hostname length from 16 to 256 chars in udhcpd, thats it.

    Beside that they moved the sources from /home/team10 to /home/iceman, so the output of a diff between .12 and .13 is huge.

    The WLAN part didn't change at all, the binary only ap85.o module in star9109/apps/libs is exactly the same as in .12.
  5. Infobits

    Infobits LI Guru Member

    Hmmm, is this the complete source code for what Linksys offers as their firmware downloads? Or is is just partial source code such that we cannot completely compile nor recreate the Linksys version completely?
    Also are you implying in your post that the wireless section of source code is not included in these tar balls (only the .object files?) It would be great if the source code for everything complete is provided.
  6. reb0

    reb0 LI Guru Member

    Yes and no.

    There is a README in the top level directory of the GPL-sources:

    It should be possible to build the firmware image although the driver for the Marvell TopDog Chipset is only available as binary module ap85.o

    I tried it with 1.00.12 but it produced many errors so I stopped it. I don't look into the problem because I wait for the 1.1.x release and hope that the GPL-sources will be released soon.
  7. Infobits

    Infobits LI Guru Member

    That does not sound good for the wireless updates part of this router. If that part of the code belongs to Marvell TopDog Chipset and company, and it is not open source, Marvell maybe is not as open to show their code as Linksys is. So maybe that is why the source code to the wireless part of the WRVS4400N router is not included in the GPL source package?
    If this is the case, I have again lost another notch of hope for fixing this routers wireless problems. Marvel has to fix their wireless firmware driver in the router as if no one can get the source code to try and figure it out and either fix and/or improve upon Marvell's buggy version. Sad if this is so. I hope not. I tried to visit Marvell's website for technical info and support or driver info and downloads and did not find a thing.
  8. markbjohnson

    markbjohnson LI Guru Member

    Firmware updated...

    Linksys just released an update (at least in the US)...

    Version: 1.00.13


    1. Allow WPA shared key to take 64 Hexadecimal digits.

    2. Display wireless MAC address under "Status->Wireless LAN" page.

    3. Enhance DHCP server to support hostname up to 63 characters
    (was limited to 15 chars).

    4. Update IPS signature file bundled inside the firmware to v1.25.

    5. Update expired SSL certificates

    6. Update "WPA Shared Key" GUI term on WPA PSK modes to be
    consistent with other products.

    7. Put port 443 in stealth mode if no VPN client configured.

    Bug fixes:

    1. Fix issue that port 443 cannot perform port forwarding
    (was reserved for QVPN).

    2. Fix issue that single port forwarding cannot work together
    with IP based ACL to limit external access.

    3. Enhance UPnP command checking to prevent illegal packet
  9. DocLarge

    DocLarge Super Moderator Staff Member Member

    Already tried it :(

    The "diag" light (at least for me) won't go out, which was a nuisance to me. I tried for a few hours and made the decision to go back to .12 for general stability. My main reason for trying .13 was to see if the PPPoE issue was fixed. PPPoe is where a lot of the linksys routers fail functionality because a majority, if not, "all" tests are conducted on either a fiber or cable (modem) connection...

  10. kspare

    kspare Computer Guy Staff Member Member

    Mine is still sitting on the shelf. :( i'm eager to use this thing!
  11. markbjohnson

    markbjohnson LI Guru Member

    1.00.13 firmware

    Using PPPOE here too...

    No problems with diag lights on mine...I'm assuming you reset and restarted with factory settings.

    The certificate issues and 443 port forwarding are definitely fixed, but I am seeing some problems with local wireless performance I hadn't seen before and also seeing UDP port scans from the AT & T DNS servers according to the IPS logs...hadn't seen that before...
  12. frpet1

    frpet1 LI Guru Member

    Any news about the new beta firmware which you should have gotten from linksys by now?
  13. kspare

    kspare Computer Guy Staff Member Member

    That beta is now available on the linksys website.
  14. frpet1

    frpet1 LI Guru Member

    Sorry but don't find it. Downloads only give me 1.00.13 stable.
    I've also tried to search on ftp.linksys.com, but without success... :confused:

    Would you be kind enough to post a link?
  15. kspare

    kspare Computer Guy Staff Member Member

    1.00.13 was the beta....as far as I know we don't even have access to any other betas to test.
  16. ChromWhiskey

    ChromWhiskey Guest

    I had Originally Firmware version and I upgraded it to and everything went wrong with VPN... Is there anyplace where i can download that firmware back??? Because all worked fine with that firmware
  17. vpnuser

    vpnuser LI Guru Member

    You might want to reset the rotuer to factory default and configure it again, if you have not done so after firmware upgrade. It will probably take you few days if you try to get old official firmware from Linksys Support.
  18. lerun

    lerun LI Guru Member

    Done some testing to.

    Firewall + IPS + QoS on

    Get about 1.8 MB/s dl from the internet.

    Using .11g i get 150kb/s dl the same file.

    Setting up a VPN connection to a router on the same subnet as above i get dl/ul of 150kb/s.

    My connection is 1900kbps / 1400 kbps.

    See no improvements disabling IPS or Firewall.

    Next I'm going to test uping the number of treads and see how the router copes.

    Using PPPoE and have had no problems keeping it connected, Firmware .13
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice