WRVS4400N connected to AM200 Modem

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by lazybeagle77, Jul 22, 2007.

  1. lazybeagle77

    lazybeagle77 LI Guru Member


    I have purchased a WRVS4400N VPN Router and a Linksys AM200 Ethernet Modem in the UK. My ISP is Plusnet and there standard connection settings are PPPoA with VC multiplexing. They also use static IP.

    Firmware version on WRVS4400N - 1.00.15
    Routers Local IP address
    Modems Local IP Address

    I have had these 2 devices working together perfectly before at my house, but I am setting this up for a small business and on transferring the 2 devices to the business premises the solution will not work.

    I have the AM200 in "Bridge Only Mode" as I want it to act as just a modem. I have it set on VC multiplexing. I have then connected it to the VPN routers WAN/Internet Port. I have set the VPN router to PPPoE an entered my the ISP details. This is where it gets weird. At my House I power the modem on first then the router after a short while the VPN router gets a public IP address, I can then get internet access from the local LAN. I then try the VPN from another remote location using Quick VPN and all works well.

    When I try the same at the business address the VPN router will not connect to the ISP (also Plusnet), unless I change the multiplexing to LLC ?? It then will connect but I start getting lots of problems with the VPN, in that when I transfer files from the client to a windows 2003 SBS I get an error stating that the remote network name is no longer available even if I use the IP address of the server in the UNC path. When I try the following from the local LAN to the internet PING uk.yahoo.com -f -l 1024 I get a reply anything bigger than this and I do not get a reply.

    I have now upgraded the WRVS4400N to Firmware 1.00.15 and now it appears to be worse in that the quickvpn client will not establish a connection at all with the router. Before I upgraded I was on 1.00.12 which allowed me to establish a VPN session.

    My questions are

    1. Am I going about this the right way ?
    2. Is the AM200 the best modem to use with the WRVS4400N, If not does anyone have any recomendations ?
    3. My house and the business premises are on different BT exchnages. Can there be differences between the exchanges that would effect the connection settings ?

    Any help on this would be greatly appreciated !
  2. TazUk

    TazUk Network Guru Member

    What do you have the MTU set to on the WRVS4400N?
  3. lazybeagle77

    lazybeagle77 LI Guru Member


    At the moment I have it set to manual 1402. This is the size that I seem to get a reply back without the packet being fragmented from the QuickVPN client. If i try to ping from the office LAN to the internet or the connected VPN client the biggest packet that will transmit without fragmentation is 1024. I have tried DRTCP on the client to set the MTU to the lower values but this did not work.

    I thnk this problem maybe occuring because of the fact that I can only get the VPN Router to connect to the ISP when i set the multiplexing to LLC on the AM200 modem ? If I set it to VC then it just will not connect. Although If I bring the 2 devices to my house and set the AM200 to VC it does work ???

    When the devices are at my house and set to VC I have no issues in copying files from the client to the win 2003 sbs server.

  4. TazUk

    TazUk Network Guru Member

    Have you spoken to PlusNet about it?
  5. lazybeagle77

    lazybeagle77 LI Guru Member

    Tried Plusnet, they were no help. Tried Linksys support multiple times, but again they were no help!
  6. lazybeagle77

    lazybeagle77 LI Guru Member

    I have now disabled IPS on the WRVS4400N and now I do not have any issues with packet sizes. I don't understand why this is. I have also set the MTU to Auto with a setting of 1472. I now just have the problem of working out why the Quick VPN software will not connect. This was working OK when I was on firmware version 1.00.12 When I first got the router I upgraded it to 1.00.13 and this also stopped Quick VPN connecting. I had quite a lot of issues with this version and put it back to 1.00.12 and Quick VPN would connect again. Now I have put it to 1.00.15 and again Quick VPN has stopped working. All I get from the client is

    Failed to establish a connection

    This could be caused by one of the following
    1. Incorrect Password
    2. No valid IP for the network card
    3. Incorrect server address
    4. You may need to disable your windows firewall

    I am sure it is none of these as just going back to 1.00.12 makes it work
  7. lazybeagle77

    lazybeagle77 LI Guru Member

    Not sure if this helps. I have read that the QuickVPN software establishes a scure tunnell over port 443. Is this correct ? If I run a port scan over the public IP address that the WRVS4400N has got I can only see 2 open ports neither of them being 443. Is this correct ?
  8. TazUk

    TazUk Network Guru Member

    Yep it will try to use 443, depending on which version of QuickVPN you're using if that fails then it will try to make a connection on port 60443.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice