WRVS4400n firmware ...

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by andrewbadera, May 24, 2007.

  1. andrewbadera

    andrewbadera LI Guru Member

    Hi all,

    I'm looking to upgrade the firmware on my newly-purchased WRVS4400n router. I understand there are issues with .13, the only release I seem to be able to find on the Linksys site. Is there someplace I can obtain .12?

    --longtime linksys guy, new linksysinfo user
  2. dcthedude

    dcthedude LI Guru Member

    if anyone has a copy of the .12 firmware, please send a copy to me
    kamikaze_jesus (at) yahoo dot com
  3. lerun

    lerun LI Guru Member

    Yeah, the .13 is a real crap.

    VPN and wireless speeds are down to 150kb/s.

    My old pre-N router does 1.9MB/s on the 11g, using a draft N card with the linksys gives me only 150kb/s.

    This is kinda strange as wireless and VPN seems to be caped at the same value, what is the ppl at linksys up to.

    Was hoping for better performance from this box.

    Also had to open the box up and put silicone on the coils, cause of the high pitched sound coming from the box.

    So if anybody got the .12 I to would like to downgrade.
  4. dcthedude

    dcthedude LI Guru Member

    I called Linksys support this morning and they informed me that their internal ftp site was down. The tech I spoke with is supposed to email the file to me when it's back up. I'll make sure to post it somewhere for you guys to download when I get it, but I wouldn't hold my breath for the Linksys tech if I were you.
  5. lerun

    lerun LI Guru Member

    Thanks, all we can do is hope. :rolleyes:

    Put if this persist I'm just going to return the router and stick with my old one.
  6. lerun

    lerun LI Guru Member

    Ok I got it from linksys.

    I'll put it up here for a short time:

    Firmware v1.00.12

  7. dcthedude

    dcthedude LI Guru Member

    Thank you Jesus...oh and you too lerun. It's a shame that a forum user can get this file to me faster than Linksys support.
  8. Toxic

    Toxic Administrator Staff Member

    Now available on our downloads section. Thanks lerun.
  9. lerun

    lerun LI Guru Member

    No problem, but it was actually Linksys Norway that got me the firmware. Looks like they where a bit faster. Only tok them one day.

    Have done a lot of testing and it seems if you use QoS on this router and set it to a lower value than you'r connections max download bandwith, the wireless connection to the internett is caped on that value.

    I have a 20Mbps/1.5Mbps connection and I set the value of 1500 in the admin console. All download from the test site (with a healthy router I get 1.9MB/s downloading) was caped at 150Kb/s. Once I turned off QoS the dl jumped to 1.4MB/s, turning off IPS gave me 1.5-1.6Mb/s (not stable though).

    This is all with .12 and a wireless connection.

    Wired with the .13 I had stable 1.8MB/s speeds....I don't know what's going on with this router...

    testing VPN I get about 250Kb/s from the same test site i get 1.8Mb/s so some improvment...but I suspect i was fooled by QoS the last time.

    Perhaps I'll go back to .13 as I had no problems with that version either.
  10. dcthedude

    dcthedude LI Guru Member

    have you guys had any problems with the wrvs losing it's configuration (returning to factory default) at random times while you are making config changes? i have 3 of these units and they are all doing it.
  11. lerun

    lerun LI Guru Member

    No such problems for me. Had to reset to factory default one time to get some settings to take but no more major problems.

    Mine was sent back because of some internal components making a high pitched sound. Probably because of the cheap inductors in the device, they start to vibrate and generate the sound when power is applied (only under load though).
  12. andrewbadera

    andrewbadera LI Guru Member


    I was off the board for a few days, busy launching a client website. any chance you could repost this please?

    thanks in advance!
  13. lerun

    lerun LI Guru Member

    It's in the download section of this site.
  14. andrewbadera

    andrewbadera LI Guru Member

    So it is, my bad! Thanks!
  15. gb115b

    gb115b LI Guru Member

    did silicone work? that noise is really annoying....
  16. hcalin

    hcalin LI Guru Member

    I have the router WRVS4400N. I did a firmware update from ver: 1.00.14 to 1.0015 and the router crashed. The power and diag front panel led lights are alternatively blinking. The router does not finish the Diag test. I left it on for at least 30 minutes. I tried a software and a hardware reset and it does not work. Not even the Hard Reset !!!! pressing the reset buton for more than 10 sec does not have any effect! this router is a semi-professional product a small business with price tag of a semi professional product (not cheap at all). I need help as it is "business critical". Voip and data link for the office are down ! Thank you, Calin
  17. Toxic

    Toxic Administrator Staff Member

  18. andrewbadera

    andrewbadera LI Guru Member

    Yours are really noisy? I think mine's silent ...
  19. yoron

    yoron Guest

  20. mat8861

    mat8861 Guest

  21. Toxic

    Toxic Administrator Staff Member

  22. morimoto

    morimoto Guest

    Looking for 1.00.16 Firmware

    Can someone please make available the 1.00.16 firmware for the WRVS4400N please? I would like to roll back to it from 1.01.03 but can't seem to find it anywhere...
  23. freshster

    freshster LI Guru Member

  24. jeru

    jeru LI Guru Member

    Are you guys getting reliable AP on this router with 1.00.16 or something? Sniffing the packets on this thing with 1.01.03 seems like the access point is physically crashing and respawning or something. You just see all traffic stop including the beacon and suddenly you see a new cell show up. (a couple of times over) I can live with the FTP problem but the access point dropping is extremely annoying for me.
  25. freshster

    freshster LI Guru Member

    I am currently using 1.01.06 and still getting the dropping issue that you describe. Maybe I will try to go back to 1.00.16 and see if it helps.
    You are right though; it is extremely annoying and frustrating. Seems like I can't go more then 1 or 2 days before the thing drops communication (even between wired and wireless computers on the same lan).

    If, or when, I try going back to 1.00.16, I will let you know if it helps.
  26. jeru

    jeru LI Guru Member

    I might avoid that if I were you. I tried using their restore utility on mine to go back to 1.00.16 and all it did was turn mine into a paper weight. Said it verified everything and rebooted the router, power light, switch lights and red diag light comes up but thats it. No amount of trying to reset it seemed to bring it back. Its just dead.
  27. freshster

    freshster LI Guru Member

    When using the upgrade utility make sure that all of the cables (LAN and WAN) are disconnected, except for the one cable you are using to restore the router. It mentions this in the upgrade utility documentation and I think it makes a difference sometimes.

    I did try 1.00.16 using the upgrade utility and it loaded fine.
    The only problem was 1.00.16 was just as buggy and unbearable.

    I then flashed the router to 1.01.03 using the upgrade utility. (For some reason, I feel the upgrade utility does a better job of loading the firmware, but that's just my opinion.) Since the upgrade utility only came with a compatible 1.00.16 firmware, you have to modify other firmware images to be compatible with the upgrade utility.

    *** WARNING *** The upgrade utility does NOT check the firmware for compatibility before flashing! It only checks that there is a WRVS4400N.bin file in the bin directory, and it grabs the version number from it. *** If you do not modify the other firmware image before using the upgrade utility to flash the device, you will brick the router, and it will register the version number as 0xffff on subsequent upgrade attempts. I had this happen to me. ***

    Good news is that I was able to successfully upgrade the same router again by modifying the original 1.01.03 firmware. I used a simple hex editor and removed the first 0200 bytes of the file. After re-saving the file, I was then able to use the new firmware image successfully with the upgrade utility. (Reboot the router if you have problems connecting to it with the upgrade utility.)

    Give it a try.
    Also, let me know if anyone wants me to upload the modified version of firmware 1.01.03 that I created for the upgrade utility.
  28. LivaditisD

    LivaditisD Network Guru Member

    hi can you upload your modified version firmware 1.01.03 i like to have a copy of it thanks..
  29. freshster

    freshster LI Guru Member

  30. LivaditisD

    LivaditisD Network Guru Member

  31. darwinmach

    darwinmach Addicted to LI Member

  32. lagaffe

    lagaffe LI Guru Member


    There is full IPV6 support with this new firmware ? Or just only IPV6 to IPV4.

    Thanks for your answer
  33. darwinmach

    darwinmach Addicted to LI Member

    It's still 6to4 (WAN IPv4, LAN v4 & v6)
  34. majster08

    majster08 Guest

    Can I use this firmware for my WRVS4400N v1.1? Or is only for WRVS4400N v1.0 ??
  35. lagaffe

    lagaffe LI Guru Member

    Thanks for your answer
  36. darwinmach

    darwinmach Addicted to LI Member

    I checked linksys's firmware links (v1.1.03) for both the v1.1 and the v1.0 and they're the same... therefore theoretically you can use this firmware on the v1.1

    i'm not exactly sure what they change because apparently the v1.1 models are only available in europe, germany in particular
  37. Toxic

    Toxic Administrator Staff Member

    The v1.1 has a different power amplifier. - parts are updated due the supplier has changed its parts catalogue and it is now not available any longer or it fixes an issue. Other than this, function wise it is the same as v1.0
  38. icea

    icea Addicted to LI Member

    WRVS4400N version 2 firmware

    Have any one firmware for WRVS4400N version 2? Thanx
  39. Toxic

    Toxic Administrator Staff Member

  40. icea

    icea Addicted to LI Member

    WRVS4400N version 2 firmware

    I have search on cisco.com, but there are no firmware for WRVS4400 version 2
  41. cmslick3

    cmslick3 Addicted to LI Member

    Is there some reason that no one is using the FW version 1.1.13?

    I have been running Firmware version 1.1.13 since shortly after purchasing my WRVS4400n. I haven't had any problems related to the router since doing that upgrade. I did follow a few steps that I think helped a lot.

    First here's the FW: Cisco WRVS4400n V1.0 V1.1 FW 1.1.13

    You have to register to get access, but I didn't have a problem with that.

    Then before you flash the fw I did the following:
    Disconnect all cables and wireless clients, except the one cable you're using to upgrade
    Reset router to factory defaults via web browser.
    After it's done reloading I performed a HARD RESET using the button on the back.
    Then I set the PC to a static IP so that the DHCP server doesn't have to do anything.
    Once the router is back up you can install the new FW.
    After it was loaded and the router was stable I did another HARD RESET.

    Finally I started putting the settings back in. Go one page at a time and be patient.
  42. cmslick3

    cmslick3 Addicted to LI Member

    V2.0 refers to the HARDWARE verison you have...

    If you are looking for the latest FW for V1.0 and 1.1 HARDWARE see my post above. I've been very happy since the upgrade.
  43. DocLarge

    DocLarge Super Moderator Staff Member Member

    The problem I found with 1.1.13 is if I was running more than 1 vpn tunnel (for example, 3), only "1" of the tunnels was indicated as running; the other two weren't even acknowledged as running.

    A lot of the feature issues with the WRVS4400N aren't going to be noticed if you're a "run-of-the-mill" user (i.e., bittorent, email, etc...). If you're a "power user" like most of us were in the now defunct (and dare I say "ill-fated") "WRV200/210 router beta test group," you found more errors in the firmware.

    It's been almost 2yrs since linksys sent me a version 1.0 WRVS4400N, and I still use it with firmware 1.1.08 to this day because it has been the most reliable. I make this statement from the standpoint that toxic and I spent time crushing it with vpn tunnels, ftp downloads, and VOIP phone calls, and 1.1.08 kicked ass!! :)

    Nothing beats it IMHO...for now...:)

  44. cmslick3

    cmslick3 Addicted to LI Member

    AHHH I understand your point. I guess being just some schmuck looking for an easy VPN access method while i'm away from home I don't have much to add...

    Thanks for the info.
  45. octopi

    octopi Addicted to LI Member

    I am using 1.1.13 since when it first released.

    As I recall pre-1.1.13 firmware had a major bug (to me at least, at the time...): When the WRVS4400N boots without any LAN connection, its DHCP server refuses to dish out any wireless users IP address until a LAN connection exists.

    Whereas DocLarge complained about >1 tunnels running with only 1 of them indicated as running. My experience is such that I often have to wait for a few seconds for the GUI (web interface) to update (needs manual reload) on the web interface. A bit slow, but it eventually tells me correct number of active connections. I have three of them connected to remote WRV54Gs plus one more for a traveling user using TheGreenBow.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice