WRVS4400N (Let's Hear The Problems...)

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by DocLarge, Dec 19, 2006.

  1. DocLarge

    DocLarge Super Moderator Staff Member Member

    I've had mine for about a week now and it appears to be more functional out of the box than my WRV200 was. IPSEC tunnel-to-tunnel VPN works although phase II has a bug in it (it throws your settings, therefore you have to "trick it") and the reboot time is bordering 2 mins...

    Other than that, has anyone else got any information on the WRVS4400N?

  2. tencylinder

    tencylinder Guest

    Can you detail the Phase II negotiation solution?


    I am having VPN issues during the phase II negotiation. Can you please give me some details on how you "trick it"?

    Thanks a ton

  3. DocLarge

    DocLarge Super Moderator Staff Member Member

    Sorry for being late on this, Bill...

    All I do in phase II is set it from "IP" to "Name" and type in the IP address. Once I've saved it for both entries, I then set it back to "IP."

    After saving, I go back and hit connect and give it a few seconds (slow response). Your tunnel should be up if the other configs are right...

  4. DocLarge

    DocLarge Super Moderator Staff Member Member


    as of late, I seem to be running into the problem of my WRVS4400N losing complete connectivity within 45 mins of reboot. My only guess is that my isp has changed something because prior to this, I had "zero" problems with the firmware I was using.

    Anyone having issues?

  5. DHCP Relay Issue and VPN Client Issue FW: V1.00.09


    Have two issues with WRVS4400N Gigabit VPN Router.

    Firmware Version: V1.00.09

    1. After activating DHCP Relay option and entering IP Address of Windows DHCP Server, receive an error message stating that the IP Address is in the wrong format. However the IP Address entered is correct and in the same subnet as the LAN IP Address.

    2. VPN Client option does not seem to resolve. Keeps stalling at final check of network settings. As well, does not seem to remove from desktop after failed attempt, and does not appear under Task Manager as application. Have to put computer into standby mode to eliminate window. Also tried this with DHCP active on local router, and still does not connect with VPN software.

    Thanks in advance.
  6. DocLarge

    DocLarge Super Moderator Staff Member Member

    Try upgrading to ver. 1.00.12 which is the latest. Regading quickvpn, you'll find it under task manager-->processes-->vpnclient.exe You should be able to kill it from there.

  7. Infobits

    Infobits LI Guru Member

    WRVS4400N buggy Wireless connections

    Hello, I am new to this forum and also a new owner of the Linksys WRVS4400N router with WPC4400N laptop adapter cards. Straight out of the box, after setting up the new router properly (I am an IT Networking Professional and know how to setup routers in general) I had and am still having difficulties with reliable wireless connections to all of my wireless PC's. I have tried just about everything I could think of and I have not been able to resolve the issues.

    The problems I am seeing are that the wireless connections would drop packets continuously at random intervals of from 10 seconds apart to minutes apart. I observe this by perfoming a continuous ping command to the router itself from each wireless client. This occurs with the router set to any of its wireless Draft-N modes (G/N only, B/G/N mixed modes).

    The situation gets much worse when I try to perform any shared files transfer from one wireless PC to another wireless PC. Doing a wireless based file transfer from a Windows XP shared drive on another wireless PC caused the ping commad to immediately start dropping packets like crazy, every second or two which of course slows down the transfer to a creeping crawl and causes the PC to become sluggish as it seems to use up the CPU resources or whatever handling the wireless communications overhead.

    The router chokes big time and cannot handle the data transfer! This also occurs when the router is set to the wireless B/G only modes!
    This occurs no matter which wireless adapters I use (Draft-N or G mode adapters). It happens with Linksys matching WPC4400N adapters and software/drivers and it happens with the laptop PC's builtin wireless G adapters as well as a few other external G mode adapters from Netgear and Dlink that I have tried.

    The problem seems to be the router itself.

    I have Time Warner RR Cable for my ISP. The WAN side connection is fine and I don't have any problems with the cable connection. The wired ports of the router seem to work fine with my wired PC's, no problems with wired connections. It is only with the wireless portion of this router that I am very NOT happy with.

    The symptoms are the same with the original firmware 1.00.09 as well as the latest new firmware 1.00.12 which is on my router now.

    Wireless connectivity will also just totally be lost and disconnect out of nowhere also. I have had this happen quite a few times almost daily now. It is the router as I had two wireless laptops in front of me, 10 feet from the router and was watching them and doing pings to the router. One was using the WPC4400N Draft-N adapter getting excellent signal saying 300Mbps speeds, the other was using it's builtin wireless G adapter with excellent signal at 54Mbps speed indicated. All of a sudden they both drop connection and then will try to reassociate with the router again. Sometimes when they do this, they can no longer see my router but they do see far away neighboring AP's. weird symtoms.

    The router's user interface could use some improvement also, for a Business Class router... should not have the router reboot at almost every config screen when entering parameters. Should allow user to enter all their desired config parameters, save and then ask if you want to reboot the router when done configuring.

    Also, where the heck is IP Address Reservations ? We can't assign ip addresses to MAC addresses anymore on this Business Class router?

    That's all I have to report for now.

    Hope that someone can get Linksys to fix these issues, especially the non functional wireless bug(s) which renders this router useless for my needs.

    and I have yet to investigate the VPN function...which everyone else seems more concerned with on this forum.
  8. swiego

    swiego LI Guru Member

    I've had some of the same problems.

    I can't figure out how to assign IP addresses to specific MAC addresses. I spent a lot of time looking through the admin site trying to figure out where this was buried because I assumed it would be there, then I started to think that maybe this feature doesn't exist at all. Then I found some old 11b router from five years ago (I think I bought it for $20) and plugged it in--lo and behold, it has this feature.

    I'm also having performance problems. Wired file transfer isn't too good but file transfer between two wireless PCs is awful. I get a couple of megabits per second. Doing those internet speed tests yields better results than a simple file transfer. I know all about network inefficiencies which is why I tried a netgear 802.11g router I have for comparison, which was twice as fast "out of the box" moving data between two wifi laptops.

    Lastly I can't get the VPN client to work under Vista (no updates posted).
  9. Infobits

    Infobits LI Guru Member

    Here is my latest update to my WRVS4400N dilema. I returned (RMA) my 1st router to the seller and ordered a 2nd new one. Got it the other day and have been testing it. This 2nd router does not seem to be dropping packets as often as the 1st router I had. It is quite stable when I do a constant ping -t test but it still occasionally will drop a packet or two every now and then. This I have concluded must be due to some RF interference I have in my neighborhood. However the major bug still remains in this router. That is the router will choke and start dropping many packets when you try to do a NETBIOS file transfer of a shared disk from one wireless PC to another wireless PC. Note that I said wireless PC to another wireless PC. Doing a wireless PC to wired PC file transfer does not cause the router to choke. Downloading from the Internet (WAN) to wireless PC works fine. It is something buggy with the router that it bogs down and chokes when doing a wireless to wireless file transfer. So I bought and tried two of these WRVS4400N routers now and they both have this wireless bug.

    Most users may never ever even notice this flaw if they don't have two wireless PC's and don't ever try to transfer a large file between wireless PC's.
    So owners and prospective buyers beware. Linksys Tech Support said that they would pass my bug report up the chain of command to be looked at. But do not know when or even if there will be a fix released. I just hope it is soon as I want to keep this router... but I am taking a big (and expensive) chance if I do keep it. It performs well in all other respects that I have tried with it.
  10. gusgez

    gusgez Guest

    great review! a bit sad though that it cant perform better for that price och promises from linksys!

    Did you have any figures on the throughput? (WAN-LAN) If you had 100/100 Mbit from your ISP or a friend that would like to share his experiences (on the throughput) I would be greatful!
  11. milkyman

    milkyman LI Guru Member


    This is my first Linksys product ever, step over from netgeaer last night.
    Bought me a WRVS4400N.
    Basicly i got 1 problem so far .. where can i lock lan ip´s to mac adresses ?
    So i dont get a new ip on a machine when i reboot it.
  12. Toxic

    Toxic Administrator Staff Member

    does the WRVS4400N support Static DHCP?
  13. milkyman

    milkyman LI Guru Member

    In the Wan section i can choose static ip .. and on the lan section i can choose to enter 3 static ip´s ... but i cant see a function to lock mac adresses to the static ip´s :sheesh:
  14. milkyman

    milkyman LI Guru Member

    Just talked to Linksys online Support and the WRVS4400N does not have this funktion ... this basicly makes me a sad man , i had my hopes up on this 1 , Its the only router on the market here that can handle my connection.
    100/100 Mbit .. and now i cant use it to reserve my servers mac adresses to local ip´s .. then i got no choise than to buy 2 other routers and split up the severs and private net through them.
    Thanks for the Quick response.
  15. Toxic

    Toxic Administrator Staff Member

    static IP for the WAN section does not do Static DHCP. if there is a Static DHCP feature it will be in the LAN Section if any.

    Just looked at the v1.00.12 firmware.


    it does not have ANY static DHCP function the 3 LAN Static IP addresses are for DNS, not for Static DHCP. unless Linksys add this in future firmwares you do not have that feature.
  16. milkyman

    milkyman LI Guru Member

    Yeah :frown:

    I got to return this baby to the store and get me another solution.
    Thanks for the help Toxic.
  17. Toxic

    Toxic Administrator Staff Member

    if it is doing what you want (except static DHCP) i would wait. linksys usually adds Static DHCP to its firmwares when new models are released.
  18. DocLarge

    DocLarge Super Moderator Staff Member Member

    Maybe I'm missing something, but why not assign the NIC in your server a static ip? DHCP is something you don't really want to be using on your crucial devices anyway (from my perspective) :)

  19. oreos

    oreos Guest

    Dear all,

    I used to have a WRT54G v2 with the DD-WRT firmware and it worked like a charm, SNMP, Syslog, telnet, wireless, everything that one dreams of and very stable. Then i upgraded my 6MBit DSL to 16MBit and needed a more powerful router to handle the traffic. That's where the WRVS4400N came to mind, it seemed to have all the features going for it.

    So much for the Powerpoint presentation. I got it, unpacked it and following do not work:

    1. Syslogd is reporting only startup and shutdown
    2. SNMP stops reporting as soon as the load goes high on the download
    3. My wireles Ethernet bridge connection always drops and even if it is online I cannot see the box behind the Ethernet bridge even if the box can see the router
    4. My GBit Ethernet performance is very unreliable (to my NAS)
    5. I have to retype my password almost every time despite the fact that firefox has saved it (must be some funny html code there)
    6. My checkpoint VPN client which uset to work with my old router on native and DD-WRT firmware (IPSec passthrough) is not working now, really depressing

    Basically this product is not worth it's bucks SW-wise and is a huge disappointment. I was forced to disconnect it until linksys comes out with a better firmware than the latest one (*.13).

    Any further feedback welcome!
  20. frpet1

    frpet1 LI Guru Member


    Now after about 1 week on 1.00.13, I also got the diag led lit up but for no ovious reason (afaik).
    The syslog, doesn't even mention that i rebooted the router to get rid of the diag light... (maybe the syslog died, and triggered the diag led?)

    I think there should be a menu-option (button/output) with the reason of why the diag led is lit up. You can click yourself exausted in the routers menu's, just to find out what's wrong. (And unfortunatly the log output wasn't any helpful...)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice