WRVS4400N New Firmware 1.01.03 Testing

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Aviator256, Nov 2, 2007.

  1. Aviator256

    Aviator256 LI Guru Member

    November 2, 2007 - High Hopes :smile: :)

    I just upgraded the firmware in the WRVS4400N to V1.1.03. :) Someone did a lot of work on this version and should be congratulated for the effort. There are many new menus and many Cisco-ish capabilities that were not present before. I truly hope the advanced capability testing goes well. If so, this router may have actually jumped from a recommended sell category to a must buy category :smile: .

    Upgrade recommendations (an ounce of prevention is worth a ton of cures) :redface:

    I found it is best to go through each menu of your old existing firmware version (before the upgrade) and create screen captures (Alt-Print Screen), paste them into a Microsoft Word Document and save the document to a file with the date and firmware version in the file name. The reason for this is that the configuration will need to be reset to the default values after the firmware upgrade. :halo: Also remember that if you are using a non-default sub-net (i.e. for VLANs or IPSec attempts, it will be defaulted to after the reset. This means that you will need to change your network properties on your local computer after the router reset to be able to communicate with the router to be able to configure it. :eek: Before going any further, I recommend physically disconnecting the router from the internet for security purposes until the new firmware configuration is complete. :rolleyes: Here is a checklist:

    1. Download firmware V1.01.03
    2. Download firmware V1.00.16 (or what ever version you presently have) some are in the download are of this site.
    3. Disconnect from the Internet
    4. Make sure your computer is physically connected to the router (don't try this using the wireless).
    5. Save the router existing configuration
    6. Screen capture the router existing configuration.
    7. Upgrade the firmware on the router.
    8. Reset/Default the router through the Web interface.
    9. Disable your network adapter (optional).
    10. Update your IP configuration (optional).
    11 Enable your network adapter.
    12. Access the router through the web interface.
    13. Authenticate using the default user/password combination.
    14. Referencing your Word Document, configure the router.
    15. For the many new settings available, leave them alone for now.
    16. Change the user/password in the Administration area to your user/password.
    17. Save the new configuration file from the web interface.
    18. Now you can play with the new settings.

    The basics seem to work well. I have not started the enhanced functions yet.
  2. Toxic

    Toxic Administrator Staff Member

    the WebGUI was just changes to give it the same feel as the other RV Series menus. QoS however maybe buggy.
  3. Aviator256

    Aviator256 LI Guru Member

    Web GUI

    With the update to the Web GUI, some missing menus were added. Such as the ability to generate administrator and user authentication keys (https:)

    I remember VPNs from v16, are VLANs new to the menus?

    Also, the ability to manipulate QoS buffers seems to be new.

    I also appreciate the port spanning, mirror and spanning tree capabilities that did not seem to be present before.

    I also noticed that the logging is now capable of logging all traffic without creating firewall rules.

    There also seems to be a couple of new SNMP traps I am picking up on my syslog.

    Thanks for the quick reply. Although rare, I was a bit enthusiastic and still am (for the moment). I may slam Linksys pretty hard when things are not working well. But, I also acknowledge and encourage professional efforts when I see them. :halo:
  4. Toxic

    Toxic Administrator Staff Member

    yeah they have brought the WRVS4400N to a higher level, its just a pity the unit did not start out like this before now. though with so many changes I am still dubious to the fact it cannot be just all good news:)
  5. swiego

    swiego LI Guru Member

    So far I am impressed. The wifi drops that were plaguing us with 1.00.16 seem to have been exorcised. The new menus are far more feature rich. Looking forward to testing this out in more detail.
  6. Aviator256

    Aviator256 LI Guru Member

    Testing Certificates, Remote Admin & QuickVPN

    So far the certificate generator seems to work well. After placing the appropriate certificate in the QuickVPN Program directory, the host validity error was resolved. :thumbup:

    The remote administration still fails in all possible configurations. :thumbdown:

    As expected (open and documented issue) the QuickVPN does not work from behind a NAT router. Even if ports 500 and 4500 are turned in (or even in a DMZ for that matter). :doh:

    Since Linksys is using Public Domain VPN software, I don't expect a remedy till the original authors fix their application. :indifferent:

    I believe Linksys is responsible for "Remote Administration" and should focus on this as an issue they can remedy in house. :poke:

    If I get a chance, I'll play with QuickVPN outside of the NAT router along with Vista and the Microsoft Vista Firewall. :jester:

    It is interesting to note that the syslog reveals the tunnel is set up properly regardless of the Vista Microsoft Firewall. The only thing that fails is the ping test as a result of the NAT router. :innocent:

    Oh. I almost forgot. I also like the little pop up warnings if you try to configure the router in such a way as to limit its capability. i.e. setting Remote Admin port to 443 pops up a QuickVPN warning. :coolest:
  7. Toxic

    Toxic Administrator Staff Member

    what problem do you have with it? Doclarge has proved to me that Remote Management works. is your WRVS4400N the gateway router?
  8. Aviator256

    Aviator256 LI Guru Member

    Remote Management

    Yep. It is setup as a gateway.
    What configuration works?
    Block WAN Requests?
    Remote Management Port?
    Remote IP Any?
    Blocks None?
    Management via WLAN?

    With Block WAN Requests off and HTTPS on, I can ping the router and perform certificate authentication. Does it make a difference If I am trying to remote manage the router from behind a NAT router?

    NAT Router --> INTERNET --> WRVS4400N
  9. DocLarge

    DocLarge Super Moderator Staff Member Member

    As Toxic said, I can remote manage my wrvs4400n. I'm using https. Additional features such as blocking cookies and active x (and so on) is disabled.

    Attached Files:

  10. Toxic

    Toxic Administrator Staff Member

    before we go any further, can you remove the router and test remote management works without the NAT router in place?
  11. wackywabbit

    wackywabbit Guest

    this does work, you can remote mng the router. with 1.1.03
  12. Aviator256

    Aviator256 LI Guru Member

    Getting Out from Behind a NAT Router for Testing

    It seems to be getting harder and harder to get a direct connection to the internet without going through some sort of security interface (my own fault). The WRVS4400N is connected to a cable modem provided by RCN. This would be a good place for a direct connect. Only the WRVS4400N is on that network. On the other end (girlfriends house), I gave her my old WCG200 Wireless-G Cable Gateway. Of course, there is no separate cable modem provided by Comcast. As a side note, Comcast continues to try to claim the WCG200 as theirs. They just can't seem to handle user provided hardware. That is one reason (of many) why I gave up on Cable Gateways and let the cable companies provide them. Back to the point, my work connection is through a proxy server. For a while, I had IIS set up at home (WRVS4400N) and was able to access it through the WCG200 and the proxy server without any issues. Of course, I had to turn in port 80 to my server and double firewall the connection with specific ACL’s. In the end I turned off the IIS because it poses too many security risks. I was simply checking the capability anyway. Do you think there might be an acceptable compromise on such as placing my Vista Laptop in the DMZ of the WCG200 or simply turning all of the ports inward (temporarily)? Yep I saw the note above and plan to place the WRVS4400N in my trusted zone in Internet Explorer which has all of the appropriate filters turned off.
  13. Aviator256

    Aviator256 LI Guru Member

    WRVS4400N Testing Continues - Wireless Remote Administration Option

    I found another interesting repeatable flaw that although not that significant can catch someone by surprise and may cause panic (like it did me at first). The default for the router is to have Wireless Remote Administration Turned off. This is a new menu item that was not there in v16. Therefore, when I was trying to gain access the router from the wireless-G connection, the router would not respond. :eek: It was like it wasn't there at all. This is really good for security. :police: I turned on the routers' response to request function and was able to ping it. Then I remembered the new menu function. :doh: I went back to the hardwired connection and changed activated the Wireless Administration capability. Thinking all was fixed, I went back to wireless and tried to access the router. It now responds and will not accept my password (access denied). :confused: I went back to the hardwired connection and it wouldn't accept my password there either. It appeared I was permanently locked out. :eek: I pulled the power plug on the router and rebooted it. :jester: Access now worked well from wired and wireless. :smile: I tried deactivating the Wireless Administration. :poke: Same thing. No access from wireless or wired connections. :wacko: After cycling power, the router allowed access from the wired connection and no longer appeared on the wireless connection. This is great for security. :police: Not so good on the heart. :sick: I believe that the appropriate fix is to have the router automatically reboot after the wireless remote administration radio button is changed (when the save button is pressed). This is how this issue is resolved in several other areas of the router and would be good to add here as well. :bow:
  14. blake_

    blake_ LI Guru Member

    You lost me at the 4th emoticon
  15. Toxic

    Toxic Administrator Staff Member

    lmao. I'm lost as it is. anyone know where I am? hehe
  16. blake_

    blake_ LI Guru Member

    I'm having problems here with poor performance streaming to my AppleTV - the streaming itself is fine, but the LAN/WAN performance of the router whilst streaming is terrible.

    Has anyone tweaked settings in this new firmware to find the best performance?
  17. Aviator256

    Aviator256 LI Guru Member

    Remote Management Not Working

    When I try to access the router remotely, I get:

    The security certificate presented by this website was not issued by a trusted certificate authority.
    The security certificate presented by this website was issued for a different website's address.

    I also attached my syslog from the attempt.

    Too bad I can not get the firewall to log access attempts.
    It would be nice if access attempts were added to the syslog.

    Any ideas?

    Attached Files:

  18. blake_

    blake_ LI Guru Member

    The cert is showing as wrong because it generates one called WRVS4400N so unless you configure your DNS or hosts file to resolve this to your router's IP address, and add the certificate as a trusted publisher, you will continue to receive this warning.
  19. Painless

    Painless LI Guru Member

    I want to download an old firmware (1.00.16)..
    I don't want to use the recovery tool..

    I cannot find the old firmware images anywhere.. Could someone post a URL or could the image be hosted on this site (as someone suggested here: http://www.linksysinfo.org/forums/showthread.php?t=55244)

    Thanks in advance :)

    P.S. Since version 1.1.03 I cannot upload files via FTP anymore.. I didn't reset to the defaults after upgrading, so I need to check that first..
  20. Aviator256

    Aviator256 LI Guru Member

    WRVS4400N Fireware 1.00.16 vs. Recovery 1.00.16

    I have 1.00.16. I simply do not how to upload it to the download area. In any case, I don't think there is a difference between the recovery version 1.00.16 presently on the Linksys site and the original 1.00.16 I have. Please let me know if you try the recovery version and find anything different.

  21. Toxic

    Toxic Administrator Staff Member

    there is no difference with the recovery tool and a binary file, The recovery tool is really a windows upgrade utility with the binary file built in. it is also safer than using webgui/upload feature.

    I do not allow uploads from users since I cannot guarantee their authenticity or any file content.
  22. Toxic

    Toxic Administrator Staff Member

    as the firmware release notes show:

    why did you not reset to factory defaults? you were keen enough to upgrade. I cannot guarantee the issue will be resolved if you reset back to factory defaults, but you cannot expect the firmware to work correctly without doing this when it is in the release notes of the firmware from linksys themselves.
  23. blake_

    blake_ LI Guru Member

    Something I've just noticed is that port 5190 connects on any outgoing IP address that I enter. Don't recall whether this happened on previous firmware, or know how to tell where this is actually connecting to (my router, software, or what).

  24. Painless

    Painless LI Guru Member

    Well, meanwhile I have reset the router to factory defaults and reset all settings by hand, and I could still not upload anything via FTP.. I've just now re-flashed the router with 'old' firmware V1.00.16, and now it works perfectly.. So this pretty much confirms it for me.. I'm sticking to version 1.00.16 for now.. (by the way I'm using Vista Business x64, if someone likes to know)..
  25. DocLarge

    DocLarge Super Moderator Staff Member Member

    I've been using FTP continuously since 1.1.03 release, and this is regarding uploading and downloading from various locations. The firmware is doing it's job...

    Something that I reported today was that the ROM takes 2 or three tries before it clears (resetting). Once you set your 4400n to factory default, you'll need to then pull the power cable, hold the reset button in, plug the power back in, and then keep holding the button down for a minimum of 45 seconds (or longer sometimes). Unfortunately, it may take a few times, but it eventually clears :(

    A clear indication that your unit has not cleared previous settings is as follows (based on what I've noticed:

    1) router is reset to factory default (i.e., ssid registers as "linksys-n) but still has previous ip range configured (i.e., 172.16.x.x instead of default
    2) DHCP will not assign ip address, thus forcing you to assign a static ip address to your computer's NIC in order to access the router's web page
    3) Under the "wireless security" tab, the default key lifetime settings of 3600 is blank, thus forcing you to type in the default

    If your router does any of these things, the ROM has not fully cleared!!! Additionally, I always disconnect any connections other than just the cable I'm using to configure the router and the power cord because on the wrv200, connections from the other ports somehow prohibited it from full setting it to default (I have no idea why *shrug* ).

    Again, this is just me speaking from personal experience, but when the router is good and cleared, firmware 1.1.03 kicks azz!!

  26. lazybeagle77

    lazybeagle77 LI Guru Member


    The WRVS4400N seems a lot more stable under firmware revision 1.01.03. I have had many issues with this router since purchase 6 months ago. At least with this firmware the router is doing most of the things I purchased it for.What amazes me is why it is so difficult to get QuickVPN working. Does anyone have any idea when QuickVPN will work under windows Vista from behind a NAT router?
  27. ianwebb

    ianwebb LI Guru Member

    Ditto lazybeagle77

    I'm with you there - any news on this would be most welcome!
  28. Metabolic

    Metabolic Guest

    Hi all,

    I have a question to this router:

    Does anybody know if there is a Firmeware out there for this router which allows me to use WDS?

    Thanks for all answers,
  29. DocLarge

    DocLarge Super Moderator Staff Member Member


    not at this time. The WRV200 is still the current "out of the box" solution on the business series side that offers WDS until further notice. I believe the WAP 4400N stock firmware may offer WDS also, but I'd have to verify that first...

    Other than that, you'd have to flash either a wrt54gl or wrt54gs with third party firmware for this functionality...

  30. Logandros

    Logandros LI Guru Member

    I have the exact same problem. I have reset this unit many times in many different ways. What I have noticed is FTP does in fact work if you reboot the router. It usually continues to work for about an hour or 2. However eventually FTP dies. You try sending files to a site and the file just hangs. Reboot the router and ftp works fine again. I have gone back to the previous firmware and the problem was resolved. Hopefully this is a known issue by the devs/support and they will address it in the next release. Unless there is a beta floting somewhere I can try, I'm stuck using the older version!
  31. Toxic

    Toxic Administrator Staff Member

    is the ftp site external ie via your wan, and if so, what type of ftp are you using? Active or Passive? Also what type of WAN connection are you on?
  32. Logandros

    Logandros LI Guru Member

    The site is external and it's not just this site, it's any external site. They all produce the same results. The FTP Client that I use is FlashFXP and I have tried sending both active and passive. I use Comcast Cable as my ISP Provider.

    Please keep in mind, I have been using the WRVS for approximately 6 months. I have had the same setup all along. Same ftp client, same isp, same few sites that I always ftp to. The only change that was made was upgrading the firmware. I also should mention that this bug only affects uploading. I can delete files, create new folders and download from sites without issue, just not upload. Same results every time, the file starts to send and stops and hangs. When I look on the ftp site there is just a 0 byte file.

    One last bit of detail in case it is relevant. I'm connected to the router via ethernet, not wireless.
  33. rhody401

    rhody401 LI Guru Member

    I have the exact same behavior, with the same new firmware and flashfxp. I'll try another client in a few. It hangs for uploads OR downloads.

    I did clear before and after upgrading, and set up all the params again manually. Rebooting does not make it work briefly, in my case

    Very frustrating :) I love the router otherwise.
  34. blake_

    blake_ LI Guru Member

    Does this happen for anyone else? Any machine in my LAN gets an open connection on port 5190 to any IP address, when infact it is connecting to the router.
  35. TMO22

    TMO22 Guest

    IPSec VPN static ip to DDNS?

    IPSec VPN supports remote gateway defined by a DDNS domain name, anyone tried this?
    I have static connection, and i try to connect to another remote gateway that is defined by a DDNS domain name. can`t get a connection.

  36. vthinsel

    vthinsel LI Guru Member


    Since I installed 1.01.03 I have one issue with DHCP: when my internet connection is down the wrvs is unable to assign DHCP addresses. I had to switch everything to static. A real pain. Beside this, I have no issues with this fw. Anyone having the same issue ?

  37. octopussy

    octopussy LI Guru Member

    Since I'm with this new firmware, DHCP server seems to be down most of the time. I had to set all my devices with static adress although it is able to assign IP address regarding the MAC.
    Also, UPnP is very unstable as after a few hours, it is down also. I then have to reboot the gateway.
    Hope to have a working firmware soon!
  38. scuba4

    scuba4 LI Guru Member

    Since the update to the new firmware I have the same behavior. I use WS_FTP and cannot up- oder download any file. I get access to the ftp-server, but if I try to send or receive any file the program hangs and after 1 minute I get an error: Socket write error, the socket has been closed.

    Greetings from Vienna
  39. DrLou

    DrLou Guest

    High gang! Can someone tell me exactly where all these firmware updates are located?

    I do see them in the GPL area on the Linksys site, and have begun to download. But are all these - very large - downloads the entire source code trees?

    TIA - Lou
  40. Toxic

    Toxic Administrator Staff Member

    if you want the firmware and not the gpl source code then goto the downloads area on www.linksys.com/downloads/ and select the type and model of your router. once you have done this, you select the model version and then you will see the firmware link for the download.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice