WUSB300N won't acquire address

Discussion in 'Other Linksys Equipment' started by mmay256, Sep 13, 2008.

  1. mmay256

    mmay256 Network Guru Member

    I have a Dell Latitude D520 and have been using a Linksys WUSB300N on it. Recently this adapter has had problems with my wireless network.

    My router is a Trendnet router set to WPA2 security.

    If I turn on the internal adapter in the laptop, it hooks up easily. If I turn the internal adapter off and connect the 300N, it sees the network and connects but usually cannot acquire an IP address. If it does acquire an address and I try to open a browser, I get the Limited or No Connectivity message.

    I have tried a second 300N with similar results. I have tried the adapters in another laptop with success.

    I have downloaded the latest drivers. Have tried it using the Linksys Network Monitor and the Windows XP manager. Rebooting doesn't help.

    I have seen lots of other people posting similar issues and have not seen any consistent solutions - I'm hoping someone here can help.


  2. mmay256

    mmay256 Network Guru Member

    Maybe a fix

    Fixed it. I think.

    I disabled the security on my router, connected the computer via the WUSB300N. It connected and I could access the internet.

    Then I re-enabled the WPA-Personal security with the same key, rebooted the laptop and IT WORKED!!!!

    The only thing I could figure was that the encryption must have gotten fouled up somehow.

    For what it's worth.

  3. Shaldares

    Shaldares Addicted to LI Member

    That happened to me a few months ago and I couldn't figure out what was wrong with it until I finally got fed up and brought the router to my computer to reconfigure it and found that I was missing a character in my WPA code.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice