WUSB54G v4 & drivers v.

Discussion in 'Other Linksys Equipment' started by icest0rm, Dec 30, 2005.

  1. icest0rm

    icest0rm Network Guru Member

    sorry m8s...here's the latest:


    RT2500USB Driver Version:
    User Interface Version:
    Release Date: 2005-11-14

    Release History:


    1. Modify OID_802_11_SUPPORTED_RATES query result.
    2. Support SESv2.
    3. With 802.1X WPA connection, if session timeout occurs, it will fail to connect even re-authentication starts.

    1. After clicking specific AP with AES of WPA-NONE to connect, it should display "AES". But it actually display "WEP".

    1. Fixed Mulitple SSID issue.
    2. Fixed WPA-None on WinXP WPA2 hot fixed.
    3. Improve WPA 2-Way Handshaking on Win9X.
    4. When SSID doesn’t exist, the link status will show connected and disconnected alternatively.

    Ralink Technology Confidential Page 3 of 3
    1. Set eighth channel of Country Region Code 11A disable.


    1. Passed WHQL.

    Fixed: 1. SelCarDlg's Friendly Name Combobox can't set sort. 2. Wep KeyLengthDescription needs initialize in ProfileSheet's AuthenPage . 3. When RadioOff to RadioOn, we should Stop SiteSurvey Autoreconnect mechanizm.
    Modify: 1. add USB\VID_1044&PID_8008 and USB\VID_050D&PID_7050 for RT73 device. 2. Just RT61 series Product can switch to AP mode. 3. InstallShield changes some folder path, so changes some code according to InstallShield. 4. nNoisePercent has minus value in LinkStatusPage -> if minus value happens, set to zero. 5. Show firmware version in AboutPage. 6. Modify WepKey Length parse error with another method when ProfilePage::SetOidFromReg(). (Use CString's length replace)

    1. Support WinXP 64bit.
    2. Add Item to switch between WZC & RaUI.
    3. Add Item to switch between WiFi mode & performance mode.
  2. icest0rm

    icest0rm Network Guru Member

    just to report my experience...with driver by Linksys I got BSOD when downloading large files on my W-LAN and streaming video from my sat decoder to my pc...now that I upgraded to by Ralink all went smooth and I can download files from my W-LAN without BSOD and windows crashing :rockon:

    be aware that to install these drivers you need to mod the inf file...I've modded it, I can post it if you want...

    cheers :thumb:
  3. darthmalak

    darthmalak Network Guru Member

    I wouldn't mind if you posted it! :)
  4. icest0rm

    icest0rm Network Guru Member

    I will make a modded package next year :rockon:
  5. darthmalak

    darthmalak Network Guru Member

    It seems I do need that modded inf file because after checking the rt2500usb.sys file installed after running the latest ralink installer, it is still which is obsolete I think... Installing through the INF doesn't have any effect.
  6. icest0rm

    icest0rm Network Guru Member

    gimme some time, just need to clean some unused lines :)
  7. darthmalak

    darthmalak Network Guru Member

    Thanks... I did make some modifactions myself but I guess I missed something....
  8. darthmalak

    darthmalak Network Guru Member

    I managed to install the 2.1 driver... I'll report back when I know more! :) So far so good.
  9. runningbird

    runningbird Network Guru Member


    some help how to install these would be really appreciated!
    I tried to install the exe package, but the only thing I got where Raillink drivers .. ?
  10. darthmalak

    darthmalak Network Guru Member

    Well... I don't know if I can be of much help but the way I see it the ralink drivers are the only thing you need. They also come with a similar configutation utility like the linksys one.

    Anyway, regarding my situation: the adapter is still not detected 90% of times when I boot up.. :( Bah... this adapter stinks.
  11. mass_konfuzion

    mass_konfuzion Network Guru Member

    Was the driver posted at Linksys.com? Cuz I didn't see it there; I got it from a windows update. Ain't that some'm??
  12. icest0rm

    icest0rm Network Guru Member

    no, you can get it directly from ralink on the link posted, linksys didn't package it yet.
  13. runningbird

    runningbird Network Guru Member

    what exactly do you have to mod to get it working?
  14. icest0rm

    icest0rm Network Guru Member

    change some reference to the linksys adapter
  15. runningbird

    runningbird Network Guru Member

    ok found it myself.
  16. Powerchicken

    Powerchicken Network Guru Member


    i read this topic with great interest, since my WUSB is causing computer freezes (still). I downloaded the driver, but i am not to experienced in modding inf files. So before i screw up anything important, can one of you post the modded inf file ?

    Thanks in advance

    Powerchicken :cheerup:
  17. MattLL

    MattLL Network Guru Member

    Is this driver version compitable with a WUSB54GS adapter?
    Was just wonderning.
  18. runningbird

    runningbird Network Guru Member

    I've send you a private message
  19. mista_eng

    mista_eng Guest

    I am also interested in updating the drivers for my WUSB54Gv4 wireless adapter. I have downloaded both the 2006/01/18 and 2005/11/21 versions but they have not worked with a simple installation session. I have located and found the rt2500esb.inf file but do not know what to do from that point onward. Any help would be very much appreciated as this device has always been, to say the least, quirky.

    Also, has WPA support been added to this device?
  20. runningbird

    runningbird Network Guru Member

    send me a pm with your email address, I'll send you my working inf file
  21. Halo

    Halo Network Guru Member

    No it isen't! :sadbye:
  22. Halo

    Halo Network Guru Member

    Download driver from "microsoft update/custom/software from other" and it will work fine! :thumbup:

    And to "runningbird" yes it has WPA-Personal and the new PSK2
  23. Deadl0ck

    Deadl0ck LI Guru Member

    Can Anyone tell me how to modify the inf file? I just downloaded the most recent installer from the ralink site ( THe RT2571W+RT2500USB one, with the RT2571W: - RT2500: drivers in it, this was the only rt2500 drivers I could find on it)

    But now I would like to know if this is the right driver, and how to get is working for my wusb54g v4. I am hoping it will solve my problems.
  24. TorinTPG

    TorinTPG LI Guru Member

    link seems dead...anyone else having this issue?
  25. Deadl0ck

    Deadl0ck LI Guru Member

    Unfortunately, this thread seems dead as well.

    anyway, the link was dead for me to, I just went to the
    http://www.ralinktech.com site, got to the driver section, and downloaded the latest RT25000 driver I could find.
  26. muenstereifel

    muenstereifel Network Guru Member

    i downloaded this package of ralink too. but i get the same "error" reported by another guy up here. after installation the driver is still 2.0.x.x.

    how do i have to modify the inf-file? can't get it working. :eek:
  27. muenstereifel

    muenstereifel Network Guru Member

    nobody an idea about that problem? :(
  28. pasquiNello

    pasquiNello LI Guru Member

    Im great interest too :biggrin:

    Can u send me inf file plz? :wink:

    Thanks in advance
  29. Deadl0ck

    Deadl0ck LI Guru Member

    Ok, so it's now, what... 5 months later? And still no help on this...

    I still had random disconnects after installing this, but a lot less frequent, and no more crashes. However, the same problem occurs again now, on a new system. *sigh* I was hoping there'd be an answer by now.

    Oh well.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice