WUSB54GC not working, just hangs on "renewing your IP"

Discussion in 'Other Linksys Equipment' started by Xpred, Dec 12, 2006.

  1. Xpred

    Xpred Network Guru Member

    I have 3 computers at home. Two of them are using Linksys WMP54G network adapters without any problems connected to a WRT54G. Now my third computer, I had bought the compact USB adapter WUSB54GC because it is a small-form factor PC and a regular PCI WMP54G adapter is too big for it.

    I am having major issues connecting to it. I can see an "Excellent" 5-bar signal, which is about right because it's only right next to the router (wall to wall). However, it never connects. It tries to connect and then hangs on "renewing your IP"... then after a minute or two, it will say "Limited or No connectivity" which does not have any connectivity at all.

    I use the Windows Wireless Zero config instead of the Linksys config. It has worked on my other computers flawlessly.

    Things I've tried: triple-checking the right WEP password, changing around channels and different data rates, downloading the Microsoft "Loop IP" SP2 fix.

    What could be possibly wrong?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice