WUSB54GS registry entries in XP

Discussion in 'Other Linksys Equipment' started by sboow, Jan 19, 2005.

  1. sboow

    sboow Network Guru Member

    Ugh, in attempting to upgrade the driver in my WUSB54GS from to 5.1.3538.0, I received an error message that the adapter could not be installed because the adapter's name "is already in use as either a service name or a service display name." Apparently, this is due to registry entries left behind in the removal of the adapter (I am running XP Home).

    Microsoft knowledge base article 823771
    prescribes a fix that involves manually deleting the adapter's registry entries from HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services.

    Does anyone know how the WUSB54GS's registry entries are named so I can know what I am deleting?

  2. kennz

    kennz Network Guru Member

    I don't have any idea regarding the registry entries, but you could reinstall using the CD again and uninstall using the utility on the CD. That should be enough to solve your problem.
  3. herberje

    herberje Network Guru Member

    If the uninstall does not work...before you attach the device. go in and stip the WUSB54GS service. Then restart it after attaching it. I also cleaned out any WUSB54 items in the registry as well as linksys, but I dont advise it if you are not that familiar with regedit. BTW the signal is still not what I expected 45-60%
  4. jagboy

    jagboy Network Guru Member

    try using system restore
  5. sboow

    sboow Network Guru Member

    Yeah - thus far system restore is the only thing I have been able to do to restore functionality back to the adapter. I still have not figured out a way to upgrade from driver to 5.1.3538.0 without encountering the problem I described above. Strange.
  6. wireLESS

    wireLESS Guest

    Are you sure the driver from the FTP site is actually 5.1.3538.0? When I downloaded the file from the driver update page (I didn't use the FTP method yet) it was the original driver ( and installer (1.05) which came on the CD-ROM with the card.
  7. howardp6

    howardp6 Network Guru Member

    The driver and firmware update page does no always, try refreshing it. The support download page for the download pag has a different name from the ftp site. As for using regedit, the Microsoft tells you to search for Linksys. You have to be very carefully using regedit, since you can render your machine unbootable if you delete the wrong entries. You should type in regedit from a run window and select edit from the menu bar or press the "f" key, while holding down the "ctrl" key. You will be prompted for a search arguement. Microsoft suggested "Linksys". I would search through the registry before deleting anything. The search next key is the F3" key. If you have other Linksys products it is more difficult. I would follow the Microsoft instructions explicitly. Be very careful. The driver entries depend on the installation exe setting, which are controlled by an "inf" or a "msi" file which the Microsoft Windows Installer uses. You can view "inf" files with notepad. You can edit "msi" files with an orca database editor. System restore keeps track of all changes to the registry, DLLs loaded and files loaded. If you had a restore point before the original installation of the WUBGS and you have not loaded software or installed other devices afterward. You may try to get back to that restore point if it exists and try running the driver installation exe, before connecting the WUB54GS.
  8. c210pilot

    c210pilot Network Guru Member

    Same Same

    My thoughts on a couple of posts here...

    1. The Linksys site links the download to the OLD version of the driver,, if you go to the FTP site you may download the NEW version, however,

    2. I have yet to find the new driver of any use. After spending a couple hours with different "tech support" people at Linksys, I have finally given up. Everytime I install the driver, I also get the error that the name is already in use.

    3. It took a while, but I finally accomplished removing all references to any Linksys product from my registry, and it took some bold deletions. I am here to say that I got lucky, but I advise anyone to be careful with the registry. OR just don't install any more versions of the driver until Linksys gets their head unlodged and starts paying more attention to the code they are writing.

    4. I don't think the communication at Linksys is above sub-par levels. Case in point, another issue that I called Linksys with, regarding certain files that run in the background when the Linksys Config. program is running the adapter, they had no idea what I was talking about and insisted that I must have a trojan or virus on my computer. It took hours, literally, of arguing with them before "I" hung up. They did not have a clue as to the files that are installed when the Setup program is ran.

    I have stuck with Linksys because they were the first to have a router with a switch and NAT on the market (for home use), but as of late, I am very dissatisfied.
  9. c210pilot

    c210pilot Network Guru Member

    Score One for the Determined

    Even more so now than ever, Linksys quality control has gone to hell in a handbasket. I ran WindowsXP Network Diagnostic and it showed me that I had 4 different Wireless connections! Well, of course I didn't, but I had uninstalled and reinstalled the Linksys adapter about that many times! So, once again, I unplugged the adapter, ran the uninstall program, ran system restore, and then went to work on the registry. Lesson learned here: Right click, Change Permissions for the key, value, etc you want to delete. I changed them to Everyone and Full Control, not the full registry, mind you, just the individual items I wanted to delete. So I deleted all the linksys, wusb and wireless connection references in the registry and after verifying they were indeed deleted, ran Registry Mechanic and rebooted. Then ran the setup program from the ver 5.xxx drivers I downloaded from the FTP site. Worked like a freakin charm, only took four months and no help from Linksys!
  10. doppler

    doppler Network Guru Member

    Open the registry with REGEDIT.
    Locate the following registry branch: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\.
    Look for the following keys under this branch: COMMCS, COMMPR, and COMMSYM. Delete these keys if you've found them (normally you should find only one of them).
    Reboot the computer.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice