WUSB54GS / WMP54GS / WMP54G driver glitch in XP workaround

Discussion in 'Other Linksys Equipment' started by Stiletto, Sep 20, 2005.

  1. Stiletto

    Stiletto Guest

    If you have a Linksys Wifi card and loaded the drivers on anything from a flat load to a long established software load, you may see the following error when you shut your system down (or start it up):

    Linksys Wireless Network Monitor: WMP54Gv4.exe - Application error.
    The instruction at "0x004ad57c" referenced memory at "0x02af1be2". The memory could not be "read".

    The addresses may change.

    This happened on a WMP54G ver 4 I recently installed for a client.

    Linksys' Wireless Network Service (in this case, WMP54GV4SVC) seems to have WLService.EXE and WMP54GV4.EXE loading as a service. Error messages when shutting down appeared approximately when Windows XP was stopping drivers.

    WMP54GV4.EXE, appearing to be simply a network monitor, may not have to execute as a service. Does WLService do all the heavy lifting?

    1. Edit registry, search for "WLSERVICE". Everytime it is found, see the words following it. In my example, the words following it were "WMP54GV4.EXE" (including quotes). Delete that phrase. Continue for each registry entry.

    2. Create new string in HKLM\Software\Microsoft\Windows\CurrentVersion\Run
    "WMP54GV4" = "C:\Program Files\Linksys Wireless-G PCI Wireless Network Monitor\WMP54GV4.EXE"

    3. Seems to work, no more crashes.

    But I do feel like something's going to cause problems, with this setup...


    I can't test this.

    So, people who are affected, please test away. Remember to back up registry before editing or set a System Restore point, I'm not liable for damages, void where prohibited, batteries not included, etc.
  2. ronco

    ronco Network Guru Member

    Me too

    I just wanted t oadd that this approach worked fine for me with a WUSB54Gv4, after substituting for that adapter where appropriate. I am running a practically new load of XP, and the latest update of the Linksys driver.

    Thanks for posting this info!
  3. Klaus_1250

    Klaus_1250 Network Guru Member

    I never really used the LinkSys-software. I have a WMP54G and the software on the CD always gave me problems. Even when I installed a v4 for someone else, problems.

    I personally prefer XP's WZC, with the Broadcom 3.xxx.xx drivers it is rockstable.
  4. ronco

    ronco Network Guru Member


    I wanted to update my last input. I found that after making this change, I had a very unstable connection. What I found I had to do was set the Linksys service to Start manually, then call it at Startup by placing the Invokesvc2.exe file in the Startup folder. I don't know why this works, but it seems to. I'm abandoning the Linksys software and trying the Windows Zero Config for a while.
  5. darthmalak

    darthmalak Network Guru Member

    You say you are abaonding your linksys software but I assume you are still using the linksys drivers?

    Should this adapter run without the WUSB54GSVC?

    BTW.. I have version 4 of the adaptor. I assume the number behind invokesvc(2, 3) stands for its version? I can't find a versions 4... hmm...
  6. mass_konfuzion

    mass_konfuzion Network Guru Member

    I have the same problems!! I disabled the WUSB54G...blahblah service and I'm using McAfee Wireless Security to connect to my network. I seem to have connection drops regardless of which program I use to actually get on the network, so I just pick the lesser of the two evils. I've never been able to stay connected for a whole day, so if someone can figure it out, please let me know!! I'll be watching this forum
  7. mass_konfuzion

    mass_konfuzion Network Guru Member

    I'm assuming you guys are talking about SP2? I'm running SP1...testing some theories on disabling UPnP before taking the leap of faith
  8. Scrufdog

    Scrufdog Network Guru Member

    ive been having problems with the Monitor randomly saying that the device isnt enabled, even though the internet stays connected. The windows wireless icon stays as if it is connected.

    any ideas?
  9. Steinar

    Steinar Guest

    disabling wmp54Gv4svc

    I was having the exact problem described at the top of this thread. WMP54Gv4.exe was crashing whenever I stopped my computer. I have an up-to-date XP system with a linksys Wireless-G PCI Adapter, model WMP54G.

    I tried something very simple to stop this problem, and it seems to have worked:

    1. I went to Control Panel/Administrative Tools/Services and changed the startup type of the WMP54Gv4SVC service to Manual and stopped the service.
    2. I restarted my computer.
    3. When the machine came up, I was not connected to my wireless network. So I connected to it. (Right click on the Wireless Network Connection icon in the lower right of your task bar, and choose View Available Wireless Networks...)
    4. Now I can restart my computer without the annoying crash of WMP54Gv4.exe, and my computer comes up just fine connected to my wireless network.

    Question: Do I NEED the WMP54Gv4SVC Windows service? Maybe it should be renamed the AnnoyingShutdownCrashSvc. :) Interested if someone has thoughts on this.

    Steinar Flatland
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice