XVortex or AdvancedTomato on EA6900 v1/v1.1 without 32k bug (renew)

Discussion in 'Other Firmware Projects' started by crashman, Mar 15, 2018.

  1. crashman

    crashman Reformed Router Member

    Theoretically you can stay on AT and do it. But since I haven't done that experiment I can't say do it like that.
    To be sure - ddwrt as normal steps.
    Your choice.
     
  2. lffoong

    lffoong New Member Member

    Can anyone upload all the files in post #1 to mega.nz/ google drive/ one drive ? I can't seems to download from Usercloud...always says "d32.usercdn.cxx" took too long to response. Thanks.
     
  3. migtoe

    migtoe New Member Member

    I uploaded files i used to zippyshare, probably better if OP gets updated though.
     
  4. lffoong

    lffoong New Member Member

    Many thanks to you migtoe. I've downloaded all the files from zippyshare that you share & I'm happy to report that I've successfully flashed my EA6900 v1 to running Vortex. :D
     
  5. AminHa

    AminHa New Member Member

    Hi @crashman
    Thank you very much for this. I saw this article just today and i am very happy to give it a try
    I have EA6700 but not sure if i should use EA6900 old stock firmware as per above instructions or i should use EA6700 old stock firmware instead?
    thx
     
    Last edited: Jan 5, 2019
  6. AminHa

    AminHa New Member Member

    All,
    Can anyone help on my question above
    Many Thanks
     
  7. AminHa

    AminHa New Member Member

    Hi again,

    I am trying to download files from original post but it seems no files in mentioned usercloud account!
    Anyone can help? at least i manged to get all files except the EA6900 custom CFE by crashman!
    Thanks
     
    Last edited: Jan 5, 2019
  8. AminHa

    AminHa New Member Member

    Hi @migtoe
    it seems uploaded files are not available in zippyshare anymore, can you help again here?

    Thanks
     
    Last edited: Jan 5, 2019
  9. migtoe

    migtoe New Member Member

  10. SyberTiger

    SyberTiger New Member Member

    I understand that there hasn't been any AdvancedTomato builds for over a year. But, I understand there's another fork called FreshTomato that has more updated releases but does not include the AdvancedTomato GUI...I'm not sure what GUI it has...I guess the standard Tomato GUI?

    Anyhow, I wonder if you might update this thread to include FreshTomato as I understand there may have been some major security issues addressed since the last time there was an AdvancedTomato release.
     
    Last edited: Jan 6, 2019
  11. crashman

    crashman Reformed Router Member

    Hi, I was abroad for a month and had no chance to read here. I'll look what is going on with files I'd uploaded.
    About EA6700 - you need exactly that CFE, not EA6900.
    About FreshTomato - if someone try it and can make explanation - do it. I'm not going to do that.

    That's all for tonight!
     
  12. crashman

    crashman Reformed Router Member

    Tested - all links from post #1 are working and downloadable.
     
  13. Renan Rufino

    Renan Rufino New Member Member

    Hello all, I was trying to install dd-wrt in my ea6900 and somehow i fall here. I read that AdvancedTomato or XVortex is better than that. I just want to do this to use my ISP router with bridge mode and 'cause the PPoE must have Vlan settings. Can someone confirm this questions? To install one of this two, I have to just follow step-by-step the guide? A lot of thanks!
    xD
     
  14. Renan Rufino

    Renan Rufino New Member Member

    Hey @crashman can help?

    PS: I was trying to do this but I'm fear to brick my router

    dd-wrt
    /phpBB2/viewtopic.php?t=291230
     
    Last edited: Feb 12, 2019
  15. Twincam

    Twincam Networkin' Nut Member

    @SyberTiger FreshTomato does indeed have the original style GUI [below]. It is under active development by kille27 and pedro311 and offers both ARM & MIPS builds. In my experience it is very stable - they have done an excellent job!

    upload_2019-2-12_15-47-57.png
     
    Last edited: Feb 13, 2019
  16. crashman

    crashman Reformed Router Member

    Hi, steps are what you need to do - nothing less or more. I couldn't understand your exact questions!

    As I did not like dd-wrt from my experience I'm not going to read all that. Guide is here, steps are correct ones but what you do is on your responsibility. Many people have done it successfully so it's not so risky.

    Good luck both of you!
     
  17. Mike Ong

    Mike Ong New Member Member

    IGNORE PLEASE.

    I was able to follow through the step again and able to load the initial flash of DD-WRT.

    ps. It would appear that EA6900 keeps 2 copies of the firmware and the tftp method uploads the firmware to the "back-up" location. From web-GUI the "rollback feature" actually bring this "back-up" firmware as the primary firmware. So the aforementioned method does work indeed.

    regards,

    ----------------------------
    hi,

    First off, thank you for the post. I just got my *2nd* EA6900 v1.1 from facebook and am trying to go through the process. I already had an EA6900 v1.0 that I converted to xvortex and now asus ac68u, so I am familiar with the process.

    That being said, I am in the same situation as you. The EA6900 v1.1 I just bought from facebook has the firmware of 1.1.42.174776 and I cannot roll-back nor upload anything to it. I have tried your method of using tftp2.exe to upload the firmware (FW_EA6900_1.1.42.158863) which, as you suggested, worked on the 3rd try.

    Also, *without* reboot, when I logged into the web server, it does say that the firmware version is 1.1.42.174776 (just as you). But what I am confused about is the following:

    What do you mean by the "firmware roll back feature"? Do you mean the "restore previous firmware" under Troubleshooting->Diagnostics, which requires internet connection?

    If so, when I did that, it got "rolled forward" to firmware 1.1.43.182871. If I reset the router again I am able to roll-back to 1.1.42.174776.

    At this point I am stuck. Any help is very much appreciated,


     
    Last edited: Mar 4, 2019
  18. Elraze

    Elraze New Member Member

    Hi,
    I was able to jump and upgrade everything but none of the links in the first post is working for me :(
     
  19. crashman

    crashman Reformed Router Member

    Hi, that's bizarre. For example: click on the link on page 1 and going to page with button "CONTINUE DOWNLOAD Confirm File?........"; when click on it goes to next step (on the same site) where to choose FREE download or PREMIUM - so click on "DOWNLOAD Slow Download Speed" (may be couple of times and close ads); then you co on step 3 (from same site, not a new tab) where in big green window you have "Download Ready! Start Downloading: ...(file name)..." and THAT's IT!

    I have no idea why is "none of the links links in the first post is working for me" :rolleyes:
     
  20. 1weirdFish

    1weirdFish New Member Member

    Did anyone have the required files downloaded successfully? I have tried for over a week now, and I am only able to download 3 files. userscloud.com is a joke, I was able to download 1 file before I signed up, and 2 files after signing up. It shows all kind of ads, asking me download all the stuff, telling me my computers has all kinds of viruses, etc., but the files I really want can't be downloaded, it drives me crazy.
    Do you know if there is another place where I can download from? Thanks in advance!
     
  21. 1weirdFish

    1weirdFish New Member Member

    Agree the links do NOT work, but thanks for all the work you have done crashman!
     
  22. crashman

    crashman Reformed Router Member

    Hi guys, all links checked 1by1 and renewed. All are working after closing some ads.
    Sorry about that!
     
  23. flotron

    flotron New Member Member

    0:macaddr=48:AB:xx:xx:xx:AB (et0macadd+2)
    1:macaddr=48:AB:xx:xx:xx:AC (et0macadd+3)


    How do i +3 or +2 a mac address that ends with letters?
     
  24. cybrnook

    cybrnook Addicted to LI Member

    0:macaddr=48:AB:xx:xx:xx:AD (et0macadd+2)
    1:macaddr=48:AB:xx:xx:xx:AF (et0macadd+3)
     
  25. flotron

    flotron New Member Member

    Thanks
     
  26. flotron

    flotron New Member Member

    What if i don't have 0:macaddr in my dump (all the others are there 1:macaddr, etc..)
     
  27. cybrnook

    cybrnook Addicted to LI Member

    then you don't have a full dump. If you have two radios (2.4 and 5.0) then you have a 0: and a 1: macaddr.
     
  28. Dbase0904

    Dbase0904 New Member Member

    Hi,

    I followed all the steps and everything went fine. but after loading tomato firmware I am unable to login with the admin username and password. Any help would be really great.
     
  29. crashman

    crashman Reformed Router Member

    Hi, that's strange. Try to reset router and load Tomato again. Image is standard so you can download it from official website. Did you try it from there?
    Or clear your web browser cache.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice