XWRT-Vortex 380.57 on R7000 problems with IPTraffic and 2.4GHz WiFi

Discussion in 'X-WRT - OpenWRT Firmware' started by TechnoSwiss, Mar 15, 2016.

  1. TechnoSwiss

    TechnoSwiss New Member Member

    Running the R7000 with R7000_378.55_2 works as expected:
    Enabling IPTraffic(per IP monitoring) will automatically disable HW acceleration (as reported on the Tools->SysInfo tab).
    Router seems to be stable without any issues.

    Running the R7000 with R7000_378.56_2 has problems:
    Enabling IPTraffic(per IP monitoring) doesn't automatically disable HW acceleration (as reported on the Tools->SysInfo tab).
    HW acceleration manually disabled (LAN->Switch Control->NAT Acceleration), since per IP monitoring doesn't work with HW acceleration enabled.
    Router seems to be stable, but ~24 hours after setup DHCP server stops handing out addresses, and DNS server stops resolving names on all interfaces wired/2.4GHz/5GHz. Using self assigned addresses can still talk to other devices on the network, and the internet. (so routing and NAT seem to be working, just DHCP and DNS are having problems).
    Rebooting the router, re-configuring/restarting DHCP doesn't solve the issue, only fix I was able to find was a factory reset.

    Running the R7000 with R7000_380.57 has problems:
    Enabling IPTraffic(per IP monitoring) locks the router up into an infinite reboot loop (if HW acceleration is enabled), only way I found out of it was a 30-30-30 reset.
    HW acceleration manually disabled allows enabling IPTraffic(per IP monitoring). However as soon as HW acceleration is disabled, the 2.4GHz interface starts having problems. Clients trying to connect have issues getting a DHCP address. If an address ever does get assigned, then DNS doesn't generally resolve. Trying to browse other network devices by IP address works occasionally, but generally times out. It acts like the 2.4GHz interface is actually working, it's just really, really, really, slow.
    As soon as HW acceleration is re-enabled (as long as IPTraffic is disabled first) the 2.4GHz interface comes right back up. (the problem happens with HW acceleration disabled, regardless of the state of IPTraffic)
    When HW acceleration is disabled and the 2.4GHz interface is having problems, the wired and 5GHz interfaces seem to work without any issues.

    I noticed in the changelog for Asuswrt-merlin 380.57 a note about fixing CTF not automatically disabled when enabling IPTraffic, is it possible that fix broke something when the code was ported to XWRT-Vortex?
     
  2. cybrnook

    cybrnook Addicted to LI Member

    380.57 has been recognized to have issues already, on R7000 and RT-AC68U (and likely other arm devices). The suggested recourse currently it to revert to 56_2.

    57 has new drivers, new SDK, and some tweaks by Merlin towards the enabling/disabling of CTF with the toggle of other options.

    Roll back to 56_2 and wait for 57_2 or 58.
     
  3. TechnoSwiss

    TechnoSwiss New Member Member

  4. Jack89

    Jack89 New Member Member

    Sorry, I came to this forum for help cause my r7000 w the latest xwrt (v380.58_0) was constantly DCing w DNS errors too. I've tried changing every option in the router and it still happens. Everything is just how you described it, with very wifi. I've reverted back to stock firmware for now. Weird thing is that I never touched IPtraffic monitor nor HW acceleration. Is .58 working out for you or still no luck?

    Also, it seems like this forum is pretty dead?
     
  5. TechnoSwiss

    TechnoSwiss New Member Member

    I had to roll back to 378.55_2 to get stable performance, but that's been solid for me the last few weeks.
     
  6. fehmi1907

    fehmi1907 Network Newbie Member

    Sorry to bump an old thread but I have exactly the same problem with 380.59 - I have a Dell laptop with Intel Centrino Wireless-N 1030 card running Windows 10 (using latest official Intel drivers for this chipset - 17.16). I have no problems with the 2.4 Ghz wireless performance while using the stock R7000 firmware. However, once I switched to 378.59, the laptop started to show the symptoms in the OP - DNS resolving failed every couple minutes and there are warnings & errors in Windows Event Viewer regarding DNS failures. Windows even tried to restart the wireless adapter a couple times because of the DNS troubles. My iPad 2 (a single band device) also has trouble with resolving and opening web pages.

    5 Ghz devices (tried a laptop, 2 iPhones, an Android tablet) or ethernet connection doesn't seem to be affected by this. I reverted back to the stock firmware and all is fine again. Does anyone have any idea how to fix this?
     
    Last edited: Jun 16, 2016
  7. TechnoSwiss

    TechnoSwiss New Member Member

    The latest firmware for this, 380.59, recently came out. I've been running it for a week on 2 different R7000 routers and it's been working great. Issues mentioned above seem to have been resolved.
     
  8. fehmi1907

    fehmi1907 Network Newbie Member

    Sorry for the typo! I was using 380.59 - I edited my initial post.

    It is weird that I have a very similar problem using the latest version. I tried changing various 2.4 Ghz wireless settings but nothing helped. I didn't think IPTraffic or hardware acceleration would have any effect on this so I didn't change them at all. Maybe I should experiment with those settings as well?

    I was going to look at more wireless settings but my router restarts itself each time I change a wireless setting. If I didn't have the problem with 2.4 Ghz wireless, I wouldn't be changing wireless settings that often and wouldn't care less about it. However, the troubleshooting becomes too cumbersome with so many restarts. I reported this restart problem in the official post and also saw a few other people mention about it as well.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice