Yet another Chillispot question, strange...

Discussion in 'DD-WRT Firmware' started by black7, Jul 7, 2005.

  1. black7

    black7 Network Guru Member

    So I've had Chillispot working for about a week now and then a week ago one morning it just stopped working. I haven't changed a thing on my WRT.

    Chilli is running, it gives out IPs, I get the login page, but everytime I go to authenticate I get a login failed message.

    I use my own web server for the captive portal, but use for my radius server.
    I've tried using chillispot's login cgi but I still get the same issue.

    I even did a factory default reset and restored from a backup I have of the WRT from when it was working.

    Any help would be greatly appreciated!
    Thanks in advance!!!

    All this has been working, then that one day it just keep failing every attempt to authenticate.
  2. black7

    black7 Network Guru Member


    Can anyone suggest any trouble shooting tips?
    Is there a way to determine if Chilli is actually trying to authenticate with the radius server?

    Any sort of help would be very much appreciated!
    Even just a link or anything.
    Thanks again! :D
  3. jagboy

    jagboy Network Guru Member

    maybe you setup chilli spotwrong. could you post your config. in the web interface. and what firmware are u running
  4. black7

    black7 Network Guru Member

    jagboy, thanks for the reply :D

    I'm using the latest and greatest DD-WRT V22 final sneak release.

    My chilli.conf looks like this :
    radiussecret XXXXXXXXXXXXXXXXX
    dhcpif br0
    dns1 x.x.x.x
    radiusnasid XXXXXXXXXX

    I first setup chilli via web interface, but since the interface only allows IPs for the radius servers I went and edited the conf file myself.
    This was working for a week or so, then one day (on the 6th of this month) it just stopped working.
  5. jagboy

    jagboy Network Guru Member

    now i heard thatto make chilli work you had to forward some ports.

    or the firewall had to be disabled.
  6. black7

    black7 Network Guru Member

    Yeah, I have all the ports open for Radius, disabled dhcp, and disabled firewall.

    What's really strange is that it WAS working, and now it just doesn't authenticate.

  7. jagboy

    jagboy Network Guru Member

    well right now if you try to ping you get this

    note the ip address it is not the ip address that it use to be. i think that chillispot servers are have problems matintaing the ip address of the site.
  8. black7

    black7 Network Guru Member

    Yeah, I noticed that too.
    I've never been able to ping their servers though.

    I actually just setup OpenWRT with Chillispot on another WRT to test things out and it is working fine.

    So, it would seem that their servers are up and functioning right now.

    I would like to use DD-WRT instead of OpenWRT in certain applications/deployments as it is more user friendly with its GUI yet very functional as well as feature rich. But if Chilli does not work well then it will limit my use of it, unfortunately.

    I'll have to do some more mucking around and testing when I get home tonight.

    I'm determined to figure this out as I did have it up and running before!!!!!
  9. black7

    black7 Network Guru Member


    So I got it working again!
    And I think I've narrowed down the problem.

    Everytime I edit the chilli.conf from scratch or use the sample chilli.conf downloaded from, chillispot would work perfectly.
    After I reboot, it would stop working!

    So, I looked at chilli.conf after a reboot and it was slightly different from the sample chilli.conf I used that works. It looks like everytime DD-WRT reboots it recreates chilli.conf.

    Anyways, all the information on the DD-WRT chilli.conf and the sample chilli.conf are the same, just the order they're listed in are different.

    Here's what my chilli.conf looks like and it seems to work perfectly.

    dns1 XXX.XXX.XXX.XXX
    radiussecret xxxsecretxxxx
    radiusnasid xxnasidxx
    dhcpif br0

    Here's what chilli.conf looks like after a reboot.

    radiusserver1 XXX.XXX.XXX.XXX
    radiusserver2 XXX.XXX.XXX.XXX
    radiussecret xxxsecretxxxx
    dhcpif br0
    dns1 XXX.XXX.XXX.XXX
    radiusnasid xxnasidxx

    So, maybe its how the conf is laid out? or maybe its like you said, Jagboy, and the IP of changed again?

    Well, whichever it is, at least chilli now works again for me. :D
  10. jagboy

    jagboy Network Guru Member

    cool good to hear. i had chillispotworking a year ago for a friend of mine but could never get mine to work.

    what are you running on your server apache for the hotspot screen.
  11. black7

    black7 Network Guru Member

    Right now its just simple PHP script.
    I'm trying to get wlogin working (check out chilli's forum for it).
    It looks pretty neat and seems to be well developed.
  12. jagboy

    jagboy Network Guru Member

    cool thnaks.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice