Yet another DHCP error with a WAG354G v2

Discussion in 'Networking Issues' started by baldrick45, Jan 8, 2007.

  1. baldrick45

    baldrick45 Guest

    Sorry if this seems familiar but I think it's different from anything else I have read on the Forum

    I recently bought a Linksys WAG354G v2 ADSL Home Gateway to go with a Lenovo 3000 N100 Laptop I had purchased for my son for Christmas.

    The router initially configured OK and connected to my BTOpenworld account. Both my own (ethernet connected PC), the lenovo laptop (wireless) and my other son's Playstation Portable (wireless) were able to connect to the router and surf the web.

    Two days ago however the Lenovo laptop stopped connecting and became unable to acquire it's IP & subnet settings from the DHCP service within the router. Nothing was changed at this time on either the router or laptop. One night it was working fine the next day it just didn't.

    Everything else continues to work - full set of green lights on the router - my PC, the PSP and even my wife's work laptop can reliably connect wirelessly too - However the Lenovo is unable to acquire an address either wirelessly or on an ethernet link. (On both adaptors all I get is an APIPA assigned address and subnet)

    If I set manually assign IP's for either wireless or ethernet adaptor I get a connected message but still cannot surf the web or even ping the router. All firewalls are disabled on the laptop - (which made no difference) and all network adaptors (Broadcom for wirless & RealTek for ethernet) have been updated to their latest drivers (no difference).

    Despite this seeming like a laptop error, I notice that this DHCP (or a very similar) error is reported on this and several other forums (fora?)for a range of Linksys gateways including 354G 54G etc..

    My firmware is already current (v 1.01.54). (At least nothing official that I can find)

    What really confuses me is that if I unplug the ethernet cable from my PC (DHCP assigned address and everything working OK) and plug it into the Lenovo ethernet I still get nothing but an error when I do "a repair network connection" or an "ipconfig /renew".

    I'm beginning to suspect some form of chipset incompatability but for this to be the cause on both adaptors strikes me as unlikely and then I keep coming back to the fact that initially everything worked perfectly....

    Anything else anyone could suggest? (I haven't tried the factory reset and reconfigure - I'll try that tonight and update this posting if this resolves the issue, even temporarily - but I don't fancy re-configuring my router every 2-3 days if this is just aother nice Linksys "feature".....)

    One other point which may even let me tryanother couple of workarounds...

    BTOpenworld - Anyone know the primary DNS settings and/or want to talk me through their full router configuration for BTO?

    All I have set is my account name and password (and it works for the other PC's) but BT seem to make it practically impossible to find meaningful addresses for anything else and my Openworld install disk is tied to the PoS USB modem they gave me, so I can't even get it to run to the point where I might find any setup details.)

    I'd like to try pointing the Lenovo on a manual IP address to a BT DNS server (since using the router address for DNS resolution seems to introduce its own problems). This might help (or then again.....)

    As you might tell from the length of post, I'm p*ssed off and going nowhere fast so any advice would be welcome.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice