Yet another WMP54G Problem

Discussion in 'Other Linksys Equipment' started by ThunderStorm, Feb 20, 2005.

  1. ThunderStorm

    ThunderStorm Network Guru Member

    Hey guys,

    I just bought a brand new WMP54G PCI adapter along with a WUSB54G(???i think? its the USB wireless G adapter), and a WRT54GX router. The PC that has the PCI adapter is running on XP SP 2 and detects the card fine. But, whenever I go to connect to my network with the WZC, it lasts only about a second or 2, if not, it wont even connect at all. When I used the Linksys Utility, I was able to establish a connection with the router, but I could not access the internet. I am almost positive this is not a router problem, seeing as how the USB is a floor above the router and works flawlessly, and I have changed tons of settings to see if I could find a combination that worked on the router. I also tried switching PCI slots to see if that would help, but no difference. I have installed/uninstalled the PCI card at least a dozen times with no sign of progress. Does anybody have any other tips or is this card just bad?

  2. linksysonline

    linksysonline Network Guru Member

    Have you tried updating the PCI Wireless card drivers?
  3. ThunderStorm

    ThunderStorm Network Guru Member

    there hasnt been an updated driver since its release :-/ but i even tried the downloaded version of the driver and still no difference
  4. linksysonline

    linksysonline Network Guru Member

    When you used the Linksys Utiliaty could you ping out? example:

    Can you ping that?

    What does your ipconfig /all look like?
  5. ThunderStorm

    ThunderStorm Network Guru Member

    I downgraded from SP 2 back to SP 1 and now I can connect to the router and the internet via the linksys utility, but I can no longer hold the connection.

    @ linksysonline
    im not sure how to/what you mean by ping out??

    but my ipconfig /all says:
    Ethernet Adapter Wireless Internet Connection:
    Media State........:Media Disconnected
    Description:Linksys Wireless-G PIC Adapter
    Physical Address:a bunch of numbers

    and thats it.

  6. Toxic

    Toxic Administrator Staff Member

    Have you tried a different PCI slot on the motherboard?

    also try sp2 with WZC enabled or disabled.

    as to the ping he means can you ping an external ip address.

    from command prompt

  7. linksysonline

    linksysonline Network Guru Member

    Start > Run > cmd

    (will give you a command prompt)

    type: ping

    What comes up?
    Any packet loss?

    When you establish a connection with the router, make sure you have all the settings right with the linksys PCI card, make sure that you ahve the right SSID, WEP etc.. if you have any of them enabled...

    When you do ipconfig /all when you have a connection (when you said you had established a connection with the router) what does it say then.. mainly in the DNS field and IP address...
  8. ThunderStorm

    ThunderStorm Network Guru Member

    How annoying -.- I had to manually enter the information for the PCI profile, so Im forcing it to use a certain IP address. It was apparently acquiring a random IP address for some reason(, and now my wireless-g USB adatper is doing it as well. Here were the results before I used the forced settings.

    Pinging with 32 bytes of data:
    Destination host unreachable.
    Destination host unreachable.
    Destination host unreachable.
    Destination host unreachable.
    Ping statistics for
    Packets: Sent = 4,Received = 0, Lost = 4 (100% Loss)
    and the ipconfig /all stats
    Connection Specific DNS Suffix..:     
    IP Address:
    So Im starting to wonder if there is a problem with the automatic settings(DHCP maybe, if thats what that is???)???

    Thanks for the help guys
  9. Toxic

    Toxic Administrator Staff Member

    you will not gain a net connection with a 169.254.*.* ip.

    if your WRT54GX is 192168.1.1 then set the IPs oth the other PC's accordingly. and

    make sure the gateways is set for
    sub mask

    and setup DNS as your ISP uses.
  10. linksysonline

    linksysonline Network Guru Member

    169.x.x.x is a default local ip if it can't find a IP address to begiven... if you connect via ethernet cable does it work fine?
  11. ThunderStorm

    ThunderStorm Network Guru Member

    the ethernet cable connected one(this one) was working fine yesterday. now apparently the entire network isnt working and im going to let it shut down for a seems the problem these computers are having is acquiring a network address, and i dont know why. but, im curious as to why the DHCP isnt letting the PCI and USB autodetect this stuff. But from what I understood I thought it had to be 192.168.1.XXX, 101 and up. Im starting to wonder if it is possibly a router setting that was set up wrong, but the USB was able to set it self up automatically. am i going to have to enter everything manually from now on??(i have done resets with the button on the back a few times and no difference, btw)

    appreciate the help guys
  12. ThunderStorm

    ThunderStorm Network Guru Member

    also forgot to mention that i reinstalled SP 2 and Norton Internet Security 2005 last night after it was working, so this also might be a problem. any known config problems with Win SP 2, WZC, or NIS 2005 and the Wireless-G PCI card??(The USB device works fine with the SP 2 on another PC)

  13. Esquire

    Esquire Mesquire Staff Member Member

    I haven't experienced any issue with my WMP54G under Windows XP SP2 or WZC (I don't use Norton products).
  14. ThunderStorm

    ThunderStorm Network Guru Member

    still out in the dark here guys, any suggestions or should i try a something like dslreports?
  15. Cold

    Cold Network Guru Member

    I have a very similar problem. Brand new WMP54G (v4 I think) cannot maintain a connection with WRT54GX for more than 5 or 6 seconds before dropping out. With the Linksys monitor running, signal strength cruises along at 70-75% and then suddenly drops into the 20s. This continues like clockwork. Running XP w/ SP2, Firewall disabled, no internet security software installed.

    At first I thought it was interference, but powering off my cordless didn't make a difference. Security settings match (I've tried WEP and unsecured, makes no difference.) I also notice that the status light on the back of the card doesn't work either (although it can see the network, so I know it's not completely dead.)

    I'm glad to hear that the USB connector works. I wonder if there isn't an incompatibility with the PCI card and the SRX router. And here I bought the linksys card to be more compatible...

    I wonder if anyone has gotten this combination to work?
  16. antonchefkok

    antonchefkok Network Guru Member

  17. Rosebud6

    Rosebud6 Guest

    I have been troublehooting a similar problem iwth my WRT54GX. If i have WEP enabled. i can connect to the internet, but not into any secure pages, I.E. Hotmail or using remote desktop. But if i turn off the WEP I have no problems logging into Hotmail. Latest Firmware. It works fine if i plug directly in, but the WEP seems to be bugged.
  18. matthiaz

    matthiaz Network Guru Member

    I've heard using the Broadcom drivers should do the trick...
  19. infoterror

    infoterror LI Guru Member

  20. rjlongo3

    rjlongo3 Guest

    WMP54G Problem

    I have been frustrated over getting this card to work. I have been to tech support 3 times with no resolution. I have a linksys WGC200 Wireless G Cable Gateway. The WMP54G is in a table top PC. Sometimes it would work, and sometimes not. It would see the wireless gateway with no problem with very good signal strength, but would sit there and search for an IP address. The way that I fixed this was to finally let it connect. When it did, I noted the IP address ( The card was set to obtain an IP address automatically. So I changed it to use a static IP address. I used the IP address noted above,, set the subnet mask for, and set the default gateway to I also set the preferred DNS server address. I checked another computer on the network to obtain the DNS server addresses. Now it all works!

    There may be other ways to fix this problem, but this solution worked for me.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice